summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdebindings-csharp')
-rw-r--r--kde-base/kdebindings-csharp/ChangeLog8
-rw-r--r--kde-base/kdebindings-csharp/kdebindings-csharp-4.3.4.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/kde-base/kdebindings-csharp/ChangeLog b/kde-base/kdebindings-csharp/ChangeLog
index 300165bc822c..79964f7af443 100644
--- a/kde-base/kdebindings-csharp/ChangeLog
+++ b/kde-base/kdebindings-csharp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdebindings-csharp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-csharp/ChangeLog,v 1.14 2009/11/30 06:54:20 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-csharp/ChangeLog,v 1.15 2009/12/01 10:19:42 wired Exp $
+
+*kdebindings-csharp-4.3.4 (01 Dec 2009)
+
+ 01 Dec 2009; Alex Alexander <wired@gentoo.org>
+ +kdebindings-csharp-4.3.4.ebuild:
+ Version bump
30 Nov 2009; Joseph Jezak <josejx@gentoo.org>
kdebindings-csharp-4.3.3.ebuild:
diff --git a/kde-base/kdebindings-csharp/kdebindings-csharp-4.3.4.ebuild b/kde-base/kdebindings-csharp/kdebindings-csharp-4.3.4.ebuild
new file mode 100644
index 000000000000..0e08ff78dcd6
--- /dev/null
+++ b/kde-base/kdebindings-csharp/kdebindings-csharp-4.3.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-csharp/kdebindings-csharp-4.3.4.ebuild,v 1.1 2009/12/01 10:19:42 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdebindings"
+KMMODULE="csharp"
+WEBKIT_REQUIRED="optional"
+inherit kde4-meta mono
+
+DESCRIPTION="C# bindings for KDE and Qt"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="akonadi +phonon plasma qscintilla"
+
+COMMON_DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep smoke 'akonadi?,phonon?,qscintilla?,webkit?')
+"
+
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+KMEXTRACTONLY="smoke/"
+
+PATCHES=( "${FILESDIR}"/${PN}-build-fixes.patch )
+
+pkg_setup() {
+ kde4-meta_pkg_setup
+
+ if use plasma && ! use webkit; then
+ eerror
+ eerror "The plasma USE flag requires the webkit USE flag to be enabled."
+ eerror
+ eerror "Please enable webkit or disable plasma."
+ die "plasma requires webkit"
+ fi
+}
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ sed -i "/add_subdirectory( examples )/ s:^:#:" csharp/plasma/CMakeLists.txt
+}
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable webkit QTWEBKIT_SHARP)
+ $(cmake-utils_use_enable plasma PLASMA_SHARP)
+ $(cmake-utils_use_enable phonon PHONON_SHARP)
+ $(cmake-utils_use_enable qscintilla QSCINTILLA_SHARP)
+ $(cmake-utils_use_enable akonadi KdepimLibs)
+ $(cmake-utils_use_enable akonadi)
+ "
+ kde4-meta_src_configure
+}
+
+src_compile() {
+ # Parallel builds seem broken, check later
+ MAKEOPTS=-j1
+ kde4-meta_src_compile
+}