summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kde-l10n/kde-l10n-4.3.1.ebuild')
-rw-r--r--kde-base/kde-l10n/kde-l10n-4.3.1.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/kde-base/kde-l10n/kde-l10n-4.3.1.ebuild b/kde-base/kde-l10n/kde-l10n-4.3.1.ebuild
deleted file mode 100644
index 1c3cbc871ed6..000000000000
--- a/kde-base/kde-l10n/kde-l10n-4.3.1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/kde-l10n-4.3.1.ebuild,v 1.4 2009/10/18 15:01:49 maekke Exp $
-
-EAPI="2"
-
-inherit kde4-base
-
-DESCRIPTION="KDE internationalization package"
-HOMEPAGE="http://www.kde.org/"
-LICENSE="GPL-2"
-
-DEPEND="sys-devel/gettext"
-RDEPEND=""
-
-KEYWORDS="~alpha amd64 ~hppa ~ia64 ~ppc ~ppc64 x86"
-IUSE="+handbook"
-
-MY_LANGS="ar bg bn_IN ca cs csb da de el en_GB es et eu fi fr ga gl gu he hi
- hne hr hu is it ja kk km kn ko ku lt lv mai mk ml mr nb nds nl nn pa pl pt
- pt_BR ro ru sk sl sr sv tg th tr uk wa zh_CN zh_TW"
-
-URI_BASE="${SRC_URI/-${PV}.tar.bz2/}"
-SRC_URI=""
-
-for MY_LANG in ${MY_LANGS} ; do
- IUSE="${IUSE} linguas_${MY_LANG}"
- SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.bz2 )"
-done
-
-S="${WORKDIR}"
-
-src_unpack() {
- local LNG DIR
- if [[ -z ${A} ]]; then
- elog
- elog "You either have the LINGUAS variable unset, or it only"
- elog "contains languages not supported by ${P}."
- elog "You won't have any additional language support."
- elog
- elog "${P} supports these language codes:"
- elog "${MY_LANGS}"
- elog
- fi
-
- [[ -n ${A} ]] && unpack ${A}
- cd "${S}"
-
- # add all linguas to cmake
- if [[ -n ${A} ]]; then
- for LNG in ${LINGUAS}; do
- DIR="${PN}-${LNG}-${PV}"
- if [[ -d "${DIR}" ]] ; then
- echo "add_subdirectory( ${DIR} )" >> "${S}"/CMakeLists.txt
- fi
- done
- fi
-}
-
-src_configure() {
- mycmakeargs="${mycmakeargs}
- $(cmake-utils_use_build handbook docs)"
- [[ -n ${A} ]] && kde4-base_src_configure
-}
-
-src_compile() {
- [[ -n ${A} ]] && kde4-base_src_compile
-}
-
-src_install() {
- [[ -n ${A} ]] && kde4-base_src_install
-}