summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/akode/akode-3.4.0_beta2.ebuild')
-rw-r--r--kde-base/akode/akode-3.4.0_beta2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/kde-base/akode/akode-3.4.0_beta2.ebuild b/kde-base/akode/akode-3.4.0_beta2.ebuild
new file mode 100644
index 000000000000..14bada75eb79
--- /dev/null
+++ b/kde-base/akode/akode-3.4.0_beta2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/akode/akode-3.4.0_beta2.ebuild,v 1.1 2005/02/05 11:39:10 danarmak Exp $
+
+KMNAME=kdemultimedia
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="aRts plugins for various formats"
+KEYWORDS="~x86"
+IUSE="flac oggvorbis speex"
+DEPEND="flac? ( media-libs/flac )
+ oggvorbis? ( media-sound/vorbis-tools )
+ speex? ( media-libs/speex )
+ !=media-libs/speex-1.1.4
+ media-libs/libsamplerate"
+
+src_compile() {
+ use oggvorbis && myconf="$myconf --with-vorbis=/usr" || myconf="$myconf --without-vorbis"
+
+ use speex && myconf="$myconf --with-extra-includes=/usr/include/speex"
+
+ kde-meta_src_compile
+}