summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-libs/gdl2/gdl2-0.11.0.ebuild')
-rw-r--r--gnustep-libs/gdl2/gdl2-0.11.0.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnustep-libs/gdl2/gdl2-0.11.0.ebuild b/gnustep-libs/gdl2/gdl2-0.11.0.ebuild
index dbab22ee1c55..3f3d059dd596 100644
--- a/gnustep-libs/gdl2/gdl2-0.11.0.ebuild
+++ b/gnustep-libs/gdl2/gdl2-0.11.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/gdl2/gdl2-0.11.0.ebuild,v 1.1 2007/12/08 18:01:38 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/gdl2/gdl2-0.11.0.ebuild,v 1.2 2008/01/20 23:39:38 voyageur Exp $
inherit gnustep-2
@@ -18,5 +18,13 @@ S=${WORKDIR}/${MY_P}
DEPEND="!gnustep-apps/sope
postgres? ( dev-db/libpq )
- sqlite? ( dev-db/sqlite )"
+ sqlite? ( >=dev-db/sqlite-3 )"
RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${P}-NSMutableDictionary.patch
+}