summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/dopewars/dopewars-1.5.9.ebuild')
-rw-r--r--games-strategy/dopewars/dopewars-1.5.9.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/games-strategy/dopewars/dopewars-1.5.9.ebuild b/games-strategy/dopewars/dopewars-1.5.9.ebuild
new file mode 100644
index 000000000000..c1569c5965d2
--- /dev/null
+++ b/games-strategy/dopewars/dopewars-1.5.9.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/dopewars/dopewars-1.5.9.ebuild,v 1.1 2003/09/10 05:27:31 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="Re-Write of the game Drug Wars"
+SRC_URI="mirror://sourceforge/dopewars/${P}.tar.gz"
+HOMEPAGE="http://dopewars.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+IUSE="nls ncurses gtk gtk2 gnome esd sdl"
+
+DEPEND="=dev-libs/glib-1.2*
+ ncurses? ( >=sys-libs/ncurses-5.2 )
+ esd? ( media-sound/esound )
+ gnome? ( gnome-base/gnome )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ gtk2? ( =x11-libs/gtk+-2* )
+ nls? ( sys-devel/gettext )
+ sdl? ( media-libs/libsdl media-libs/sdl-mixer )"
+
+src_compile() {
+ local myservconf=""
+ if [ `use gtk` ] || [ `use gtk2` ] ; then
+ myservconf="--enable-gui-server `use_enable gtk2 glib2`"
+ else
+ myservconf="--disable-gui-client"
+ fi
+
+ egamesconf \
+ `use_enable ncurses curses-client` \
+ `use_enable nls` \
+ `use_with sdl` \
+ `use_with esd` \
+ --enable-networking \
+ --enable-plugins \
+ ${myservconf} \
+ || die
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ cd ${D}/${GAMES_DATADIR}
+ use gnome \
+ && mv gnome ../ \
+ || rm -rf gnome
+ mv pixmaps ../
+ dohtml -r doc/*/*
+ rm -rf doc
+ rm dopewars.sco
+
+ prepgamesdirs
+}