summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/avp-cvs/avp-cvs-20030314.ebuild')
-rw-r--r--games-fps/avp-cvs/avp-cvs-20030314.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-fps/avp-cvs/avp-cvs-20030314.ebuild b/games-fps/avp-cvs/avp-cvs-20030314.ebuild
new file mode 100644
index 000000000000..63762e0c0bc8
--- /dev/null
+++ b/games-fps/avp-cvs/avp-cvs-20030314.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/avp-cvs/avp-cvs-20030314.ebuild,v 1.1 2003/09/09 18:10:14 vapier Exp $
+
+ECVS_PASS="anonymous"
+ECVS_SERVER="icculus.org:/cvs/cvsroot"
+ECVS_MODULE="avp"
+inherit cvs games
+
+DESCRIPTION="Linux port of Aliens vs Predator"
+HOMEPAGE="http://www.icculus.org/avp/"
+
+LICENSE="AvP"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="x11-base/xfree
+ media-libs/openal
+ media-libs/libsdl
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/${ECVS_MODULE}
+
+src_compile() {
+ sed -i \
+ -e "/^CFLAGS =/s:=.*:=${CFLAGS}:" Makefile || \
+ die "sed Makefile failed"
+ make || die "make failed"
+}
+
+src_install() {
+ dogamesbin AvP
+ dodoc README TODO
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo "please follow the instructions in"
+ einfo "/usr/share/doc/${PF}/README.gz"
+ einfo "to install the rest of the game"
+}