summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/domination/domination-1.1.1.4.ebuild')
-rw-r--r--games-board/domination/domination-1.1.1.4.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/games-board/domination/domination-1.1.1.4.ebuild b/games-board/domination/domination-1.1.1.4.ebuild
deleted file mode 100644
index 0c8be2e98dd9..000000000000
--- a/games-board/domination/domination-1.1.1.4.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/domination/domination-1.1.1.4.ebuild,v 1.1 2013/05/03 01:03:18 mr_bones_ Exp $
-
-inherit eutils java-pkg-2 java-ant-2 games
-
-DESCRIPTION="The well-known board game, written in java"
-HOMEPAGE="http://domination.sourceforge.net"
-SRC_URI="mirror://sourceforge/domination/Domination_${PV}.zip"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE=""
-
-RDEPEND=">=virtual/jre-1.4"
-DEPEND=">=virtual/jdk-1.4
- app-arch/unzip"
-
-S=${WORKDIR}/Domination
-
-pkg_setup() {
- games_pkg_setup
- java-pkg-2_pkg_setup
-}
-
-EANT_BUILD_TARGET="game"
-
-src_compile() {
- java-pkg-2_src_compile
-}
-
-src_install() {
- mkdir -p "${D}${GAMES_PREFIX}"/bin
- cp "${S}"/FlashGUI.sh "${D}${GAMES_PREFIX}"/bin/${PN} || die
- sed -i \
- -e "s|cd.*|cd \"${GAMES_DATADIR}\"/${PN}|" \
- "${D}${GAMES_PREFIX}"/bin/${PN} \
- || die
- chmod +x "${D}${GAMES_PREFIX}"/bin/${PN} || die
-
- insinto "${GAMES_DATADIR}/${PN}"
- doins -r "${S}"/* || die
- rm -f "${D}${GAMES_DATADIR}"/${PN}/*.cmd || die
- java-pkg_regjar "${D}/${GAMES_DATADIR}/${PN}"/*.jar
-
- newicon resources/icon.png ${PN}.png
- make_desktop_entry ${PN} "Domination"
-
- prepgamesdirs
-}