summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/biloba/biloba-0.9.3.ebuild')
-rw-r--r--games-board/biloba/biloba-0.9.3.ebuild26
1 files changed, 20 insertions, 6 deletions
diff --git a/games-board/biloba/biloba-0.9.3.ebuild b/games-board/biloba/biloba-0.9.3.ebuild
index 982debf928cf..4e30b7e07ed2 100644
--- a/games-board/biloba/biloba-0.9.3.ebuild
+++ b/games-board/biloba/biloba-0.9.3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/biloba/biloba-0.9.3.ebuild,v 1.6 2014/08/10 21:21:32 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/biloba/biloba-0.9.3.ebuild,v 1.7 2014/09/12 07:00:31 mr_bones_ Exp $
-EAPI=2
-inherit autotools eutils games
+EAPI=5
+inherit autotools eutils gnome2-utils games
DESCRIPTION="a board game, up to 4 players, with AI and network"
HOMEPAGE="http://biloba.sourceforge.net/"
@@ -17,6 +17,7 @@ IUSE=""
DEPEND="media-libs/libsdl:0[X,video,sound]
media-libs/sdl-image[png]
media-libs/sdl-mixer"
+RDEPEND=${DEPEND}
src_prepare() {
# X11 headers are checked but not used, everything is done through SDL
@@ -30,9 +31,22 @@ src_prepare() {
}
src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog README
- newicon biloba_icon.png ${PN}.png
+ default
+ newicon -s 64 biloba_icon.png ${PN}.png
make_desktop_entry biloba Biloba
prepgamesdirs
}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}