summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/bzrtools/bzrtools-2.1.0.ebuild')
-rw-r--r--dev-vcs/bzrtools/bzrtools-2.1.0.ebuild53
1 files changed, 31 insertions, 22 deletions
diff --git a/dev-vcs/bzrtools/bzrtools-2.1.0.ebuild b/dev-vcs/bzrtools/bzrtools-2.1.0.ebuild
index 7bb5cc255960..d80f367dd6fd 100644
--- a/dev-vcs/bzrtools/bzrtools-2.1.0.ebuild
+++ b/dev-vcs/bzrtools/bzrtools-2.1.0.ebuild
@@ -1,43 +1,52 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzrtools/bzrtools-2.1.0.ebuild,v 1.4 2010/07/10 19:12:32 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzrtools/bzrtools-2.1.0.ebuild,v 1.5 2010/07/14 21:44:57 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
-inherit eutils distutils versionator
+inherit distutils eutils versionator
DESCRIPTION="bzrtools is a useful collection of utilities for bzr."
HOMEPAGE="http://bazaar-vcs.org/BzrTools"
-SRC_URI=""https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz""
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~x86-macos"
IUSE=""
+#IUSE="test"
-DEPEND="=dev-vcs/bzr-$(get_version_component_range 1-2)*"
-RDEPEND="${DEPEND}"
+RDEPEND="=dev-vcs/bzr-$(get_version_component_range 1-2)*"
+DEPEND="${RDEPEND}"
+# test? ( dev-python/testtools )
-#RESTRICT="test"
+RESTRICT="test"
-DOCS="AUTHORS CREDITS NEWS NEWS.Shelf README README.Shelf TODO TODO.heads TODO.Shelf"
-
-S=${WORKDIR}/${PN}
+S="${WORKDIR}/${PN}"
-PYTHON_MODNAME=bzrlib
+DOCS="AUTHORS CREDITS NEWS NEWS.Shelf README README.Shelf TODO TODO.heads TODO.Shelf"
+PYTHON_MODNAME="bzrlib/plugins/bzrtools"
src_test() {
- einfo "Running testsuite..."
- # put a linked copy of the bzr core into the build directory to properly
- # test the "built" version of bzrtools
- find "$(python_get_libdir)/site-packages/bzrlib/" \
- -mindepth 1 -maxdepth 1 \
- \( \( -type d -and -not -name "plugins" \) -or -name "*.py" \) \
- -exec ln -s '{}' "${S}/build/lib/bzrlib/" \;
- touch "${S}/build/lib/bzrlib/plugins/__init__.py"
- "${S}/test.py" "${S}/build/lib" || die
- # remove the "shadow" copy so it doesn't get installed
- rm "${S}/build/lib/bzrlib/plugins/__init__.py"
- find "${S}/build/lib/bzrlib/" -mindepth 1 -maxdepth 1 -type l -exec rm '{}' \;
+ testing() {
+ local return_status="0"
+
+ # put a linked copy of the bzr core into the build directory to properly
+ # test the "built" version of bzrtools
+ find "$(python_get_libdir)/site-packages/bzrlib/" \
+ -mindepth 1 -maxdepth 1 \
+ \( \( -type d -and -not -name "plugins" \) -or -name "*.py" \) \
+ -exec ln -s '{}' "${S}/build-${PYTHON_ABI}/lib/bzrlib/" \;
+ touch "${S}/build-${PYTHON_ABI}/lib/bzrlib/plugins/__init__.py"
+ "${S}/test.py" "${S}/build-${PYTHON_ABI}/lib" || return_status="1"
+ # remove the "shadow" copy so it doesn't get installed
+ rm "${S}/build-${PYTHON_ABI}/lib/bzrlib/plugins/__init__.py"
+ find "${S}/build-${PYTHON_ABI}/lib/bzrlib/" -mindepth 1 -maxdepth 1 -type l -exec rm '{}' \;
+
+ return "${return_status}"
+ }
+ python_execute_function testing
}