summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/strace/files/digest-strace-4.2-r21
-rw-r--r--dev-util/strace/strace-4.2-r2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-util/strace/files/digest-strace-4.2-r2 b/dev-util/strace/files/digest-strace-4.2-r2
new file mode 100644
index 000000000000..a5694effe782
--- /dev/null
+++ b/dev-util/strace/files/digest-strace-4.2-r2
@@ -0,0 +1 @@
+MD5 4702419bfccbc025b9f10141bcf1ee9a strace-4.2.tar.gz
diff --git a/dev-util/strace/strace-4.2-r2.ebuild b/dev-util/strace/strace-4.2-r2.ebuild
new file mode 100644
index 000000000000..5340777bc634
--- /dev/null
+++ b/dev-util/strace/strace-4.2-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.2-r2.ebuild,v 1.1 2000/11/14 14:57:55 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A usefull diagnostic, instructional, adn debugging tool"
+SRC_URI="http://www.wi.leidenuniv.nl/~wichert/strace/${A}"
+HOMEPAGE="http://www.wi.leidenuniv.nl/~wichert/strace/"
+DEPEND=">=sys-libs/glibc-2.1.3"
+
+src_unpack () {
+ unpack ${A}
+ cd ${S}
+ if [ -n "`use glibc22`" ]
+ then
+ cp ${FILESDIR}/stream.c .
+ fi
+ cp time.c time.c.orig
+ sed -e 's:<linux/timex\.h>:"linux/timex\.h":' time.c.orig > time.c
+ cp ${FILESDIR}/timex.h linux
+
+}
+src_compile() {
+
+ cd ${S}
+ try ./configure --prefix=/usr i486-linux
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ doman strace.1
+ dobin strace
+ dobin strace-graph
+ dodoc ChangeLog COPYRIGHT CREDITS NEWS PORTING README* TODO
+
+}
+
+
+
+