summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/motor/motor-3.3.0-r1.ebuild')
-rw-r--r--dev-util/motor/motor-3.3.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/motor/motor-3.3.0-r1.ebuild b/dev-util/motor/motor-3.3.0-r1.ebuild
new file mode 100644
index 000000000000..ca2b585de579
--- /dev/null
+++ b/dev-util/motor/motor-3.3.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/motor/motor-3.3.0-r1.ebuild,v 1.1 2006/08/22 10:14:18 liquidx Exp $
+
+inherit eutils
+
+DESCRIPTION="text mode based programming environment for Linux"
+HOMEPAGE="http://thekonst.net/en/motor"
+SRC_URI="http://thekonst.net/download/motor-3.3.0.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ppc x86"
+IUSE="nls"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc34-2.patch"
+ epatch "${FILESDIR}/motor-3.2.2-security.patch"
+}
+
+src_compile() {
+ econf `use_enable nls` || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ dodoc AUTHORS COPYING README TODO FAQ ChangeLog
+ docinto tutorial
+ dohtml -r tutorial/*
+}