summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/text-format/text-format-1.0.0-r4.ebuild')
-rw-r--r--dev-ruby/text-format/text-format-1.0.0-r4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/text-format/text-format-1.0.0-r4.ebuild b/dev-ruby/text-format/text-format-1.0.0-r4.ebuild
new file mode 100644
index 000000000000..2517897badf3
--- /dev/null
+++ b/dev-ruby/text-format/text-format-1.0.0-r4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/text-format/text-format-1.0.0-r4.ebuild,v 1.1 2013/12/19 23:56:20 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README Changelog ToDo"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Text::Format provides strong text formatting capabilities to Ruby"
+HOMEPAGE="http://rubyforge.org/projects/text-format/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend '>=dev-ruby/text-hyphen-1.0.0'
+ruby_add_bdepend "test? ( dev-ruby/archive-tar-minitar )"
+
+all_ruby_prepare() {
+ # Fix rakefile for new rake versions
+ sed -i -e 's: if t\.verbose::' Rakefile || die
+}