summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-ldap/ruby-ldap-0.8.1.ebuild')
-rw-r--r--dev-ruby/ruby-ldap/ruby-ldap-0.8.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/ruby-ldap/ruby-ldap-0.8.1.ebuild b/dev-ruby/ruby-ldap/ruby-ldap-0.8.1.ebuild
new file mode 100644
index 000000000000..49915efe9101
--- /dev/null
+++ b/dev-ruby/ruby-ldap/ruby-ldap-0.8.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-ldap/ruby-ldap-0.8.1.ebuild,v 1.1 2003/11/24 16:15:08 agriffis Exp $
+
+DESCRIPTION="A Ruby interface to some LDAP libraries"
+HOMEPAGE="http://ruby-ldap.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ruby-ldap/${P}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~arm ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="ssl"
+DEPEND=">=dev-lang/ruby-1.6
+ >=net-nds/openldap-2
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+ ruby extconf.rb --with-openldap2
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc ChangeLog README* TODO
+}