summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ws4py/ws4py-0.2.3.ebuild')
-rw-r--r--dev-python/ws4py/ws4py-0.2.3.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/ws4py/ws4py-0.2.3.ebuild b/dev-python/ws4py/ws4py-0.2.3.ebuild
deleted file mode 100644
index 475ea0fefb9d..000000000000
--- a/dev-python/ws4py/ws4py-0.2.3.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ws4py-0.2.3.ebuild,v 1.4 2013/07/19 07:56:00 mgorny Exp $
-
-# We could depend on dev-python/cherrypy when USE=server, but
-# that is an optional component ...
-# Same for www-servers/tornado and USE=client ...
-
-EAPI="4"
-PYTHON_DEPEND="*:2.6"
-SUPPORT_PYTHON_ABIS="1"
-DISTUTILS_SRC_TEST="py.test"
-
-inherit distutils eutils
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://github.com/Lawouach/WebSocket-for-Python.git"
- inherit git-2
-else
- inherit vcs-snapshot
- SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/tarball/v${PV} -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-
-DESCRIPTION="WebSocket support for Python"
-HOMEPAGE="https://github.com/Lawouach/WebSocket-for-Python"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="+client +server test +threads"
-
-RDEPEND="client? ( dev-lang/python[threads?] )"
-DEPEND="test? (
- ${RDEPEND}
- dev-python/unittest2
- >=dev-python/cherrypy-3.2.0
- dev-python/gevent
- )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.2-cherrypy_test.patch
- distutils_src_prepare
-}
-
-src_install() {
- distutils_src_install
- use client || rm -rf "${ED}$(python_get_sitedir)"/ws4py/client
- use server || rm -rf "${ED}$(python_get_sitedir)"/ws4py/server
-}