summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/twisted-runner/twisted-runner-10.2.0.ebuild')
-rw-r--r--dev-python/twisted-runner/twisted-runner-10.2.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/twisted-runner/twisted-runner-10.2.0.ebuild b/dev-python/twisted-runner/twisted-runner-10.2.0.ebuild
new file mode 100644
index 000000000000..3de162b51b5c
--- /dev/null
+++ b/dev-python/twisted-runner/twisted-runner-10.2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-runner/twisted-runner-10.2.0.ebuild,v 1.1 2010/12/22 21:53:54 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+MY_PACKAGE="Runner"
+
+inherit twisted versionator
+
+DESCRIPTION="Twisted Runner is a process management library and inetd replacement."
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="=dev-python/twisted-$(get_version_component_range 1)*"
+RDEPEND="${DEPEND}"
+
+PROVIDE="virtual/inetd"
+
+PYTHON_MODNAME="twisted/runner"