summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/testify/testify-0.3.3.ebuild')
-rw-r--r--dev-python/testify/testify-0.3.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/testify/testify-0.3.3.ebuild b/dev-python/testify/testify-0.3.3.ebuild
new file mode 100644
index 000000000000..9ea00c7510e9
--- /dev/null
+++ b/dev-python/testify/testify-0.3.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/testify-0.3.3.ebuild,v 1.1 2014/06/03 10:53:39 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+RESTRICT="test" # basically broken
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="A more pythonic replacement for the unittest module and nose"
+HOMEPAGE="https://github.com/Yelp/testify http://pypi.python.org/pypi/testify/"
+SRC_URI="https://github.com/Yelp/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+DOCS="README.md"
+
+src_prepare_all() {
+ # Rm rogue test, Bug #438032
+ rm -f test/plugins//http_reporter_test.py
+}
+
+python_test() {
+ "${PYTHON}" bin/${PN} test || die
+}