summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-mhash/python-mhash-1.2.ebuild')
-rw-r--r--dev-python/python-mhash/python-mhash-1.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-mhash/python-mhash-1.2.ebuild b/dev-python/python-mhash/python-mhash-1.2.ebuild
new file mode 100644
index 000000000000..84a7ae7d4d6e
--- /dev/null
+++ b/dev-python/python-mhash/python-mhash-1.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-mhash/python-mhash-1.2.ebuild,v 1.1 2004/05/24 06:39:18 robbat2 Exp $
+
+inherit distutils
+
+DESCRIPTION="Python interface to libmhash"
+SRC_URI="mirror://sourceforge/mhash/${P}.tar.gz"
+HOMEPAGE="http://mhash.sourceforge.net/"
+DEPEND="virtual/python
+ app-crypt/mhash"
+IUSE=""
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+
+src_unpack() {
+ unpack ${A}
+ # fix a glitch for gcc3.3 compiling
+ sed '231s/$/\\/' -i ${S}/mhash.c
+}
+
+src_install() {
+ mydoc="AUTHORS LICENSE NEWS PKG-INFO README"
+ distutils_src_install
+}