summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-docs/python-docs-2.5.4-r1.ebuild')
-rw-r--r--dev-python/python-docs/python-docs-2.5.4-r1.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/dev-python/python-docs/python-docs-2.5.4-r1.ebuild b/dev-python/python-docs/python-docs-2.5.4-r1.ebuild
index de91f6f7b91a..80cc955fcb1d 100644
--- a/dev-python/python-docs/python-docs-2.5.4-r1.ebuild
+++ b/dev-python/python-docs/python-docs-2.5.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.5.4-r1.ebuild,v 1.4 2009/09/27 18:39:53 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.5.4-r1.ebuild,v 1.5 2009/10/11 11:22:18 grobian Exp $
DESCRIPTION="HTML documentation for Python"
HOMEPAGE="http://www.python.org/doc/"
@@ -8,7 +8,7 @@ SRC_URI="http://www.python.org/ftp/python/doc/${PV}/html-${PV}.tar.bz2"
LICENSE="PSF-2.2"
SLOT="2.5"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE=""
DEPEND=">=app-admin/eselect-python-20090606"
@@ -22,10 +22,11 @@ src_unpack() {
}
src_install() {
+ [[ -z ${ED} ]] && local ED=${D}
docinto html
- cp -R "${S}/Python-Docs-${PV}/"* "${D}/usr/share/doc/${PF}/html"
+ cp -R "${S}/Python-Docs-${PV}/"* "${ED}/usr/share/doc/${PF}/html"
- echo "PYTHONDOCS_${SLOT//./_}=\"/usr/share/doc/${PF}/html\"" > "60python-docs-${SLOT}"
+ echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html\"" > "60python-docs-${SLOT}"
doenvd "60python-docs-${SLOT}"
}
@@ -44,11 +45,12 @@ pkg_postinst() {
}
pkg_postrm() {
+ [[ -z ${EROOT} ]] && local EROOT=${ROOT}
eselect_python_update
if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then
- rm -f "${ROOT}etc/env.d/65python-docs"
+ rm -f "${EROOT}etc/env.d/65python-docs"
fi
- rm -f "${ROOT}etc/env.d/50python-docs"
+ rm -f "${EROOT}etc/env.d/50python-docs"
}