summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pysolr/pysolr-3.3.2.ebuild')
-rw-r--r--dev-python/pysolr/pysolr-3.3.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pysolr/pysolr-3.3.2.ebuild b/dev-python/pysolr/pysolr-3.3.2.ebuild
new file mode 100644
index 000000000000..ae77c1b0a970
--- /dev/null
+++ b/dev-python/pysolr/pysolr-3.3.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysolr/pysolr-3.3.2.ebuild,v 1.1 2015/06/15 15:05:42 mrueg Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Lightweight python wrapper for Apache Solr"
+HOMEPAGE="https://pypi.python.org/pypi/pysolr/ http://github.com/toastdriven/pysolr/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"