summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyopencl/pyopencl-2011.2.ebuild')
-rw-r--r--dev-python/pyopencl/pyopencl-2011.2.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/pyopencl/pyopencl-2011.2.ebuild b/dev-python/pyopencl/pyopencl-2011.2.ebuild
deleted file mode 100644
index eb64a3d8fb4f..000000000000
--- a/dev-python/pyopencl/pyopencl-2011.2.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/pyopencl-2011.2.ebuild,v 1.4 2012/02/25 01:56:21 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-inherit distutils
-
-DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="http://mathema.tician.de/software/pyopencl"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples opengl"
-
-RDEPEND="<dev-libs/boost-1.48[python]
- >=dev-python/numpy-1.0.4
- dev-python/pytools
- virtual/opencl"
-DEPEND="${RDEPEND}"
-
-src_configure()
-{
- if use opengl; then
- myconf="${myconf} --cl-enable-gl"
- fi
-
- "$(PYTHON -f)" ./configure.py --boost-python-libname=boost_python-mt \
- --boost-compiler=gcc ${myconf}
- sed -i -e 's/USE_SHIPPED_BOOST = True/USE_SHIPPED_BOOST = False/' siteconf.py
-}
-
-src_install()
-{
- distutils_src_install
- insinto /usr/share/doc/${PF}
- if use examples; then
- doins -r examples || die
- fi
-}
-
-pkg_postinst()
-{
- distutils_pkg_postinst
- if use examples; then
- elog "Some of the examples provided by this package require dev-python/matplotlib."
- fi
-}