summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygame/pygame-1.6.ebuild')
-rw-r--r--dev-python/pygame/pygame-1.6.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pygame/pygame-1.6.ebuild b/dev-python/pygame/pygame-1.6.ebuild
new file mode 100644
index 000000000000..12ffcbed20a8
--- /dev/null
+++ b/dev-python/pygame/pygame-1.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.6.ebuild,v 1.1 2003/12/13 06:57:57 kloeri Exp $
+
+inherit distutils
+
+DESCRIPTION="python bindings to sdl and other libs that facilitate game production"
+SRC_URI="http://www.pygame.org/ftp/${P}.tar.gz"
+HOMEPAGE="http://www.pygame.org/"
+
+IUSE=""
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/python
+ >=media-libs/libsdl-1.2.5
+ >=media-libs/sdl-ttf-2.0.6
+ >=media-libs/sdl-image-1.2.2
+ >=media-libs/sdl-mixer-1.2.4
+ >=dev-python/numeric-22.0
+ >=media-libs/smpeg-0.4.4-r1"
+
+
+src_install () {
+ mydoc=WHATSNEW
+ distutils_src_install
+
+ dohtml -r docs/*
+ insinto /usr/share/doc/${PF}/examples
+ doins ${S}/examples/*
+ insinto /usr/share/doc/${PF}/examples/data
+ doins ${S}/examples/data/*
+}
+