summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/h5py/h5py-1.3.1.ebuild')
-rw-r--r--dev-python/h5py/h5py-1.3.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/h5py/h5py-1.3.1.ebuild b/dev-python/h5py/h5py-1.3.1.ebuild
new file mode 100644
index 000000000000..595791a22df5
--- /dev/null
+++ b/dev-python/h5py/h5py-1.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/h5py/h5py-1.3.1.ebuild,v 1.1 2011/05/03 22:20:58 bicatali Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+DESCRIPTION="A simple Python interface to HDF5 files."
+HOMEPAGE="http://h5py.alfven.org/ http://code.google.com/p/h5py/ http://pypi.python.org/pypi/h5py"
+SRC_URI="http://h5py.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sci-libs/hdf5-1.6.7
+ dev-python/numpy"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"