summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/argparse/argparse-1.0.1.ebuild')
-rw-r--r--dev-python/argparse/argparse-1.0.1.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/dev-python/argparse/argparse-1.0.1.ebuild b/dev-python/argparse/argparse-1.0.1.ebuild
index 8a51a0c476a6..ea2833b4cfeb 100644
--- a/dev-python/argparse/argparse-1.0.1.ebuild
+++ b/dev-python/argparse/argparse-1.0.1.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/argparse/argparse-1.0.1.ebuild,v 1.1 2009/10/20 19:46:33 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/argparse/argparse-1.0.1.ebuild,v 1.2 2009/11/04 11:02:55 arfrever Exp $
+EAPI="2"
SUPPORT_PYTHON_ABIS="1"
inherit distutils
DESCRIPTION="Provides an easy, declarative interface for creating command line tools."
-HOMEPAGE="http://code.google.com/p/argparse/"
+HOMEPAGE="http://code.google.com/p/argparse/ http://pypi.python.org/pypi/argparse"
SRC_URI="http://argparse.googlecode.com/files/${P}.zip"
LICENSE="Apache-2.0"
@@ -17,4 +18,10 @@ IUSE=""
DEPEND=""
RDEPEND=""
-RESTRICT_PYTHON_ABIS="3.*"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test/test_argparse.py
+ }
+ python_execute_function testing
+}