summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/perltidy/perltidy-20070508.ebuild')
-rw-r--r--dev-perl/perltidy/perltidy-20070508.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/perltidy/perltidy-20070508.ebuild b/dev-perl/perltidy/perltidy-20070508.ebuild
new file mode 100644
index 000000000000..f58d873acfdc
--- /dev/null
+++ b/dev-perl/perltidy/perltidy-20070508.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/perltidy/perltidy-20070508.ebuild,v 1.1 2007/05/12 14:38:20 mcummings Exp $
+
+inherit perl-module
+
+S=${WORKDIR}/${P/perltidy/Perl-Tidy}
+DESCRIPTION="Perl script indenter and beautifier."
+HOMEPAGE="http://perltidy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/perltidy/${P/perltidy/Perl-Tidy}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+SRC_TEST="do"
+
+mydoc="examples/*"
+
+mymake="/usr"
+
+pkg_postinst() {
+ elog "Example scripts can be found in /usr/share/doc/${P}"
+}
+
+
+DEPEND="dev-lang/perl"