summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/pomap/pomap-2.9.4.ebuild')
-rw-r--r--dev-ml/pomap/pomap-2.9.4.ebuild15
1 files changed, 5 insertions, 10 deletions
diff --git a/dev-ml/pomap/pomap-2.9.4.ebuild b/dev-ml/pomap/pomap-2.9.4.ebuild
index 319dbb1ca4eb..1b5928b15067 100644
--- a/dev-ml/pomap/pomap-2.9.4.ebuild
+++ b/dev-ml/pomap/pomap-2.9.4.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pomap/pomap-2.9.4.ebuild,v 1.1 2004/08/08 09:28:17 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pomap/pomap-2.9.4.ebuild,v 1.2 2004/08/25 12:48:48 mattam Exp $
+
+inherit findlib
DESCRIPTION="Partially Ordered Map ADT for O'Caml"
HOMEPAGE="http://www.ai.univie.ac.at/~markus/home/ocaml_sources.html"
LICENSE="LGPL-2.1"
-DEPEND=">=dev-lang/ocaml-3.06
- >=dev-ml/findlib-0.8"
+DEPEND=">=dev-lang/ocaml-3.06"
SRC_URI="http://www.oefai.at/~markus/ocaml_sources/${P}.tar.bz2"
SLOT="0"
@@ -18,13 +19,7 @@ src_compile() {
}
src_install () {
- # which directory does the lib go into?
- destdir=`ocamlfind printconf destdir`
-
- # install
- mkdir -p ${D}${destdir} || die
- make OCAMLFIND_DESTDIR=${D}${destdir} \
- OCAMLFIND_LDCONF=dummy install || die
+ findlib_src_install
# install documentation
dodoc LICENSE README VERSION Changes