summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild')
-rw-r--r--dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild b/dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild
index b70eda7b3b02..e3623b148c7b 100644
--- a/dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild
+++ b/dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild,v 1.4 2013/03/03 14:48:44 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild,v 1.5 2015/03/17 15:58:49 aballier Exp $
EAPI=5
-inherit findlib
+inherit findlib eutils
DESCRIPTION="OCaml SDL Bindings"
@@ -14,10 +14,10 @@ LICENSE="LGPL-2"
SLOT="0/${PV}"
KEYWORDS="~amd64 ppc x86"
-IUSE="doc opengl truetype" #noimage nomixer
+IUSE="doc +ocamlopt opengl truetype" #noimage nomixer
RDEPEND="
- >=dev-lang/ocaml-3.04:=
+ >=dev-lang/ocaml-3.12:=[ocamlopt=]
>=media-libs/libsdl-1.2
opengl? ( >=dev-ml/lablgl-0.98:= )
>=media-libs/sdl-mixer-1.2
@@ -26,6 +26,10 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}/ocamlopt.patch"
+}
+
src_configure() {
myconf=""
if use opengl; then