summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libgcrypt/ChangeLog18
-rw-r--r--dev-libs/libgcrypt/files/digest-libgcrypt-1.1.31
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.1.3.ebuild33
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/libgcrypt/ChangeLog b/dev-libs/libgcrypt/ChangeLog
new file mode 100644
index 000000000000..52982ffc9d99
--- /dev/null
+++ b/dev-libs/libgcrypt/ChangeLog
@@ -0,0 +1,18 @@
+# ChangeLog for dev-libs/atlas
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/ChangeLog,v 1.1 2002/03/15 10:02:15 seemant Exp $
+
+*libgcrypt-1.1.3 (15 Mar 2002 )
+
+ 15 Mar 2002; Seemant Kulleen <seemant@gentoo.org> ChangeLog :
+
+ This library is necessary for the new release of aide (intrusion detection)
+ version 0.8
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/dev-libs/libgcrypt/files/digest-libgcrypt-1.1.3 b/dev-libs/libgcrypt/files/digest-libgcrypt-1.1.3
new file mode 100644
index 000000000000..37b9c78ba6cb
--- /dev/null
+++ b/dev-libs/libgcrypt/files/digest-libgcrypt-1.1.3
@@ -0,0 +1 @@
+MD5 054ccfe199ab1465e8a8890aefd03d87 libgcrypt-1.1.3.tar.gz 505561
diff --git a/dev-libs/libgcrypt/libgcrypt-1.1.3.ebuild b/dev-libs/libgcrypt/libgcrypt-1.1.3.ebuild
new file mode 100644
index 000000000000..cd5a51428baf
--- /dev/null
+++ b/dev-libs/libgcrypt/libgcrypt-1.1.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Christian Rubbert <crubb@xrc.de>
+
+S=${WORKDIR}/${P}
+DESCRIPTION="libgcrypt is a general purpose crypto library based on the code used in GnuPG."
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/alpha/libgcrypt/${P}.tar.gz"
+HOMEPAGE="http://www.gnupg.org"
+
+DEPEND="virtual/glibc
+ app-text/jadetex
+ app-text/docbook2X
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING INSTALL KNOW-BUGS NEWS README THANKS TODO doc/README.* doc/example.c
+}