summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/ffcall/ffcall-1.8d.ebuild')
-rw-r--r--dev-libs/ffcall/ffcall-1.8d.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/dev-libs/ffcall/ffcall-1.8d.ebuild b/dev-libs/ffcall/ffcall-1.8d.ebuild
index 15b5ef43d2ae..44c9b0a54d0b 100644
--- a/dev-libs/ffcall/ffcall-1.8d.ebuild
+++ b/dev-libs/ffcall/ffcall-1.8d.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ffcall/ffcall-1.8d.ebuild,v 1.8 2003/02/13 10:37:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ffcall/ffcall-1.8d.ebuild,v 1.9 2003/12/12 22:23:51 gmsoft Exp $
DESCRIPTION="foreign function call libraries"
SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/libs/${P}.tar.gz"
@@ -11,10 +11,19 @@ HOMEPAGE="http://www.gnu.org/directory/ffcall.html"
# under GNU LGPL." -ffcall author
LICENSE="GPL-2 | LGPL-2"
SLOT="0"
-KEYWORDS="x86 sparc "
+KEYWORDS="x86 sparc ~hppa"
DEPEND="virtual/glibc"
+
+src_unpack()
+{
+ unpack ${A}
+ #Fix hppa asm
+ use hppa && (cd ${S}; epatch ${FILESDIR}/ffcall_hppa_1.8-4.2.diff.gz)
+
+}
+
src_compile() {
econf || die "./configure failed"
make || die