summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ruby-cvs/ruby-cvs-1.8.2.ebuild')
-rw-r--r--dev-lang/ruby-cvs/ruby-cvs-1.8.2.ebuild94
1 files changed, 94 insertions, 0 deletions
diff --git a/dev-lang/ruby-cvs/ruby-cvs-1.8.2.ebuild b/dev-lang/ruby-cvs/ruby-cvs-1.8.2.ebuild
new file mode 100644
index 000000000000..beea124fbb2c
--- /dev/null
+++ b/dev-lang/ruby-cvs/ruby-cvs-1.8.2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby-cvs/ruby-cvs-1.8.2.ebuild,v 1.1 2004/06/30 19:00:15 usata Exp $
+
+IUSE="socks5 tcltk"
+
+inherit flag-o-matic alternatives gnuconfig cvs
+filter-flags -fomit-frame-pointer
+
+DESCRIPTION="An object-oriented scripting language"
+HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI=""
+
+LICENSE="Ruby"
+SLOT="1.8"
+KEYWORDS="~alpha ~hppa ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/gdbm-1.8.0
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ dev-util/gperf
+ socks5? ( >=net-misc/dante-1.1.13 )
+ tcltk? ( dev-lang/tk )
+ sys-apps/findutils
+ >=dev-ruby/ruby-config-0.2"
+RDEPEND="${DEPEND}
+ !=dev-lang/ruby-1.8*"
+PROVIDE="virtual/ruby"
+
+ECVS_SERVER="cvs.ruby-lang.org:/src"
+ECVS_MODULE="ruby"
+ECVS_AUTH="pserver"
+ECVS_PASS="anonymous"
+ECVS_UP_OPTS="-dP -rruby_1_8"
+ECVS_CO_OPTS="-rruby_1_8"
+
+S=${WORKDIR}/${ECVS_MODULE}
+
+src_compile() {
+
+ local ruby_version=`gawk '$2=="RUBY_VERSION" {print $3}' version.h | tr -d \"`
+ if [ "${PV}" != "${ruby_version}" ]; then
+ die "version mismatch"
+ fi
+
+ # Socks support via dante
+ if ! use socks5 ; then
+ # Socks support can't be disabled as long as SOCKS_SERVER is
+ # set and socks library is present, so need to unset
+ # SOCKS_SERVER in that case.
+ unset SOCKS_SERVER
+ fi
+
+ # Increase GC_MALLOC_LIMIT if set (default is 8000000)
+ if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
+ CFLAGS="${CFLAGS} -DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
+ export CFLAGS
+ fi
+
+ autoconf || die "autoconf failed"
+
+ # disable install-doc because of yaml/parser
+ econf --program-suffix=${SLOT/./} --enable-shared \
+ `use_enable socks5 socks` \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall DESTDIR=${D} || die "einstall failed"
+
+ dosym /usr/lib/libruby${SLOT/./}.so.${PV} /usr/lib/libruby.so.${PV%.*}
+ dosym /usr/lib/libruby${SLOT/./}.so.${PV} /usr/lib/libruby.so.${PV}
+
+ dodoc COPYING* ChangeLog MANIFEST README* ToDo
+}
+
+pkg_postinst() {
+
+ if [ ! -n "$(readlink /usr/bin/ruby)" ] ; then
+ /usr/sbin/ruby-config ruby${SLOT/./}
+ fi
+ einfo
+ einfo "You can change the default ruby interpreter by /usr/sbin/ruby-config"
+ einfo
+}
+
+pkg_postrm() {
+
+ if [ ! -n "$(readlink /usr/bin/ruby)" ] ; then
+ /usr/sbin/ruby-config ruby${SLOT/./}
+ fi
+}