summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/jsch/jsch-0.1.18.ebuild')
-rw-r--r--dev-java/jsch/jsch-0.1.18.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-java/jsch/jsch-0.1.18.ebuild b/dev-java/jsch/jsch-0.1.18.ebuild
index bde78c146b2e..aa6c1f692bc5 100644
--- a/dev-java/jsch/jsch-0.1.18.ebuild
+++ b/dev-java/jsch/jsch-0.1.18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jsch/jsch-0.1.18.ebuild,v 1.11 2005/07/09 16:05:14 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jsch/jsch-0.1.18.ebuild,v 1.12 2005/09/10 17:39:10 axxo Exp $
inherit java-pkg
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
LICENSE="jcraft"
SLOT="0"
KEYWORDS="x86 amd64 ppc sparc ppc64"
-IUSE="doc jikes source"
+IUSE="doc jikes source examples"
RDEPEND=">=virtual/jdk-1.4
>=dev-java/jzlib-1.0.3
@@ -37,5 +37,9 @@ src_install() {
java-pkg_newjar dist/lib/jsch*.jar jsch.jar
use doc && java-pkg_dohtml -r javadoc/*
use source && java-pkg_dosrc src/*
+ if use examples; then
+ dodir /usr/share/doc/${PF}/examples/
+ cp -r examples/* ${D}/usr/share/doc/${PF}/examples/ || die
+ fi
dodoc README ChangeLog
}