summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/jamvm/jamvm-1.3.0.ebuild')
-rw-r--r--dev-java/jamvm/jamvm-1.3.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-java/jamvm/jamvm-1.3.0.ebuild b/dev-java/jamvm/jamvm-1.3.0.ebuild
new file mode 100644
index 000000000000..1a50afec7a3b
--- /dev/null
+++ b/dev-java/jamvm/jamvm-1.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jamvm/jamvm-1.3.0.ebuild,v 1.1 2005/04/01 18:51:08 luckyduck Exp $
+
+inherit eutils
+
+DESCRIPTION="An extremely small and specification-compliant Java virtual machine."
+HOMEPAGE="http://jamvm.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/jamvm/jamvm-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug"
+DEPEND=">=dev-java/gnu-classpath-0.14"
+RDEPEND=">=dev-java/gnu-classpath-0.14"
+
+src_compile() {
+ # compiles JamVM
+ cd ${S}
+
+ # configure adds "/share/classpath" itself
+ myc="--with-classpath-install-dir=/usr"
+ use debug && myc="${myc} --enable-tracelock"
+ econf ${myc} || die "configure failed."
+ emake || die "make failed."
+}
+
+src_install() {
+ make install-strip DESTDIR=${D} || die "installation failed."
+
+ # puts jni.h in a package dependent folder
+ cd ${D}usr/include
+ mkdir ${P}
+ mv jni.h ${P}
+}