summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/ant-apache-bsf/ant-apache-bsf-1.8.0.ebuild')
-rw-r--r--dev-java/ant-apache-bsf/ant-apache-bsf-1.8.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-java/ant-apache-bsf/ant-apache-bsf-1.8.0.ebuild b/dev-java/ant-apache-bsf/ant-apache-bsf-1.8.0.ebuild
new file mode 100644
index 000000000000..df9c97ca5de3
--- /dev/null
+++ b/dev-java/ant-apache-bsf/ant-apache-bsf-1.8.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-apache-bsf/ant-apache-bsf-1.8.0.ebuild,v 1.1 2010/02/21 00:21:08 caster Exp $
+
+EAPI=2
+
+ANT_TASK_DEPNAME="bsf-2.3"
+
+inherit eutils ant-tasks
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# ant-nodeps contains <script> task which is needed for this
+# although it's not a build dep through import
+DEPEND=">=dev-java/bsf-2.4.0-r1:2.3[python?,javascript?,tcl?]"
+RDEPEND="${DEPEND}
+ ~dev-java/ant-nodeps-${PV}"
+
+IUSE="python javascript tcl"
+
+JAVA_PKG_FILTER_COMPILER="jikes"
+
+src_install() {
+ ant-tasks_src_install
+ java-pkg_register-dependency ant-nodeps
+}
+
+pkg_postinst() {
+ elog "Also, >=dev-java/bsf-2.4.0-r1 adds optional support for groovy,"
+ elog "ruby and beanshell. See its postinst elog messages for instructions."
+}