summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/hk_classes/hk_classes-0.7.2_alpha3.ebuild')
-rw-r--r--dev-db/hk_classes/hk_classes-0.7.2_alpha3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-db/hk_classes/hk_classes-0.7.2_alpha3.ebuild b/dev-db/hk_classes/hk_classes-0.7.2_alpha3.ebuild
new file mode 100644
index 000000000000..52b6a4d4079c
--- /dev/null
+++ b/dev-db/hk_classes/hk_classes-0.7.2_alpha3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hk_classes/hk_classes-0.7.2_alpha3.ebuild,v 1.1 2004/11/08 22:26:27 carlo Exp $
+
+P_DOCS="hk_docs-0.7"
+
+MY_P=${P/_alpha/-test}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="GUI-independent C++ libraries for database applications, including API documentation and tutorials."
+HOMEPAGE="http://hk-classes.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hk-classes/${MY_P}.tar.bz2
+ mirror://sourceforge/knoda/knodapython.tar.bz2
+ mirror://sourceforge/knoda/${P_DOCS}.tar.bz2"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86 ~ppc"
+IUSE="mysql postgres sqlite odbc doc"
+
+# At least one of the following is required
+DEPEND="mysql? ( >=dev-db/mysql-3.23.54a )
+ postgres? ( >=dev-db/postgresql-7.3 )
+ sqlite? ( >=dev-db/sqlite-2* )
+ odbc? ( >=dev-db/unixODBC-2.0.6 )"
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ use doc && dohtml -r ${WORKDIR}/${P_DOCS}/*
+ use doc && dohtml -r ${WORKDIR}/knodapythondoc
+ make DESTDIR=${D} install || die
+}