summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/sash/sash-3.4-r5.ebuild')
-rw-r--r--app-shells/sash/sash-3.4-r5.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-shells/sash/sash-3.4-r5.ebuild b/app-shells/sash/sash-3.4-r5.ebuild
new file mode 100644
index 000000000000..132ce1a2bd42
--- /dev/null
+++ b/app-shells/sash/sash-3.4-r5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r5.ebuild,v 1.1 2002/03/14 21:17:14 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A small static UNIX Shell with readline suppport"
+SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz
+ http://dimavb.st.simbirsk.su/vlk/sash-3.x-readline.diff.gz"
+HOMEPAGE="http://www.canb.auug.org.au/~dbell/ http://dimavb.st.simbirsk.su/vlk/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/zlib-1.1.4
+ readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )"
+
+RDEPEND=""
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+
+ if [ "`use readline`" ]
+ then
+ gzip -dc ${DISTDIR}/sash-3.x-readline.diff.gz | patch -p1
+
+ cp Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" -e "s:-ltermcap:-lncurses:" Makefile.orig > Makefile
+ else
+ cp Makefile Makefile.orig
+ sed -e "s:-O3:${CFLAGS}:" Makefile.orig > Makefile
+ fi
+}
+
+src_compile() {
+
+ make || die
+
+}
+
+src_install() {
+
+ into /
+ dobin sash
+ into /usr
+ doman sash.1
+ dodoc README
+
+}
+