summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-sci/qcad/qcad-2.0.2.0.ebuild')
-rw-r--r--app-sci/qcad/qcad-2.0.2.0.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/app-sci/qcad/qcad-2.0.2.0.ebuild b/app-sci/qcad/qcad-2.0.2.0.ebuild
new file mode 100644
index 000000000000..6a1e974e00f4
--- /dev/null
+++ b/app-sci/qcad/qcad-2.0.2.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/qcad/qcad-2.0.2.0.ebuild,v 1.1 2004/02/11 13:04:22 phosphan Exp $
+
+inherit kde-functions
+
+MY_P=${P}-1.src
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A 2D CAD package based upon Qt."
+SRC_URI="http://www.ribbonsoft.com/archives/qcad/${MY_P}.tar.gz"
+HOMEPAGE="http://www.ribbonsoft.com/qcad.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+need-qt 3
+
+DEPEND="${DEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${MY_P}-gentoo.patch
+ cd ${S}/scripts
+ sed -i -e 's/^make/make ${MAKEOPTS}/' build_qcad.sh
+ sed -i -e 's/^\.\/configure/.\/configure --host=${CHOST}/' build_qcad.sh
+}
+
+
+src_compile() {
+ ### borrowed from kde.eclass #
+ #
+ # fix the sandbox errors "can't writ to .kde or .qt" problems.
+ # this is a fake homedir that is writeable under the sandbox, so that the build process
+ # can do anything it wants with it.
+ REALHOME="$HOME"
+ mkdir -p $T/fakehome/.kde
+ mkdir -p $T/fakehome/.qt
+ export HOME="$T/fakehome"
+ # things that should access the real homedir
+ [ -d "$REALHOME/.ccache" ] && ln -sf "$REALHOME/.ccache" "$HOME/"
+ cd scripts
+ sh build_qcad.sh || die "build failed"
+}
+
+src_install () {
+ cd qcad
+ mv qcad qcad.bin
+ dobin qcad.bin
+ echo -e "#!/bin/sh\ncd /usr/share/${P}\nqcad.bin" > qcad
+ chmod ugo+rx qcad
+ dobin qcad
+ dodir /usr/share/${P}
+ cp -a patterns examples fonts scripts qm ${D}/usr/share/${P}
+ cd ..
+ dodoc README
+ dohtml -r qcad/doc
+}
+