summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/jbidwatcher/jbidwatcher-0.9.7_pre2.ebuild')
-rw-r--r--app-misc/jbidwatcher/jbidwatcher-0.9.7_pre2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-misc/jbidwatcher/jbidwatcher-0.9.7_pre2.ebuild b/app-misc/jbidwatcher/jbidwatcher-0.9.7_pre2.ebuild
new file mode 100644
index 000000000000..a4f5fe971845
--- /dev/null
+++ b/app-misc/jbidwatcher/jbidwatcher-0.9.7_pre2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/jbidwatcher/jbidwatcher-0.9.7_pre2.ebuild,v 1.1 2005/04/26 15:28:58 luckyduck Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Ebay Bidder Tools for Sniping"
+HOMEPAGE="http://jbidwatcher.sf.net/"
+SRC_URI="mirror://sourceforge/jbidwatcher/${P/_/}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="jikes"
+
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant
+ jikes? ( dev-java/jikes )"
+RDEPEND=">=virtual/jre-1.4"
+
+S=${WORKDIR}/${P/_/}
+
+src_compile() {
+ sed -i 's:${user.home}/.jbidwatcher:.:' build.xml
+ sed -i 's:jikes:modern:' build.xml
+ # Fix bad build.xml
+ sed -i 's:<fileset dir="${src.dir}" includes="jbidwatcher.properties">:<fileset dir="${src.dir}" includes="jbidwatcher.properties" />:' build.xml
+ sed -i '/taskdef/d' build.xml
+
+ local antflags="jar"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant ${antflags} || die "compilation failed"
+}
+
+src_install() {
+ mv *.jar ${PN}.jar
+ java-pkg_dojar ${PN}.jar
+
+ echo "#!/bin/sh" > ${PN}
+ echo '$(java-config -J) -jar $(java-config -p jbidwatcher) $*' >> ${PN}
+
+ dobin ${PN}
+}