summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/xen/xen-3.1.0.ebuild')
-rw-r--r--app-emulation/xen/xen-3.1.0.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-emulation/xen/xen-3.1.0.ebuild b/app-emulation/xen/xen-3.1.0.ebuild
index 7b0f04236c38..dcc4d72fbaac 100644
--- a/app-emulation/xen/xen-3.1.0.ebuild
+++ b/app-emulation/xen/xen-3.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.1.0.ebuild,v 1.1 2007/08/24 23:22:32 marineam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.1.0.ebuild,v 1.2 2007/08/27 17:19:12 marineam Exp $
inherit mount-boot flag-o-matic
@@ -26,7 +26,9 @@ QA_WX_LOAD="boot/xen-syms-${PV}"
pkg_setup() {
if [[ -z ${XEN_TARGET_ARCH} ]]; then
- if use x86; then
+ if use x86 && use amd64; then
+ die "Confusion! Both x86 and amd64 are set in your use flags!"
+ elif use x86; then
export XEN_TARGET_ARCH="x86_32"
elif use amd64; then
export XEN_TARGET_ARCH="x86_64"