summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/riece/riece-8.0.0.ebuild')
-rw-r--r--app-emacs/riece/riece-8.0.0.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/app-emacs/riece/riece-8.0.0.ebuild b/app-emacs/riece/riece-8.0.0.ebuild
index fe7e4ba55320..9e19418124b9 100644
--- a/app-emacs/riece/riece-8.0.0.ebuild
+++ b/app-emacs/riece/riece-8.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/riece/riece-8.0.0.ebuild,v 1.6 2012/09/30 18:07:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/riece/riece-8.0.0.ebuild,v 1.7 2014/08/29 20:21:43 ulm Exp $
EAPI=4
@@ -19,7 +19,7 @@ RESTRICT="test"
SITEFILE="50${PN}-gentoo.el"
src_configure() {
- econf --with-lispdir="${SITELISP}"
+ econf --with-lispdir="${EPREFIX}${SITELISP}"
}
src_compile() {
@@ -27,14 +27,15 @@ src_compile() {
}
src_install () {
- einstall lispdir="${D}/${SITELISP}"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
-
+ emake DESTDIR="${D}" \
+ lispdir="${ED}${SITELISP}" \
+ install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
dodoc AUTHORS NEWS README doc/HACKING lisp/ChangeLog*
if use linguas_ja; then
dodoc NEWS.ja README.ja doc/HACKING.ja
else
- rm -f "${D}"/usr/share/info/riece-ja.info*
+ rm -f "${ED}"/usr/share/info/riece-ja.info*
fi
}