summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/doxygen/doxygen-1.4.4.ebuild')
-rw-r--r--app-doc/doxygen/doxygen-1.4.4.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/app-doc/doxygen/doxygen-1.4.4.ebuild b/app-doc/doxygen/doxygen-1.4.4.ebuild
index 44b9a4a0ad1b..7d0ab27f30b1 100644
--- a/app-doc/doxygen/doxygen-1.4.4.ebuild
+++ b/app-doc/doxygen/doxygen-1.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.4.ebuild,v 1.3 2005/10/06 20:48:54 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.4.ebuild,v 1.4 2005/10/08 16:47:34 grobian Exp $
inherit eutils
@@ -23,11 +23,12 @@ DEPEND=">=sys-apps/sed-4
src_unpack() {
unpack ${A}
cd ${S}
- # use CFLAGS and CXXFLAGS
+ # use CFLAGS and CXXFLAGS (on linux and ppc-macos)
sed -i.orig -e "s:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= ${CFLAGS}:" \
-e "s:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= ${CXXFLAGS}:" \
- tmake/lib/linux-g++/tmake.conf
+ tmake/lib/{linux-g++,macosx-c++}/tmake.conf
epatch ${FILESDIR}/doxygen-1.4.3-cp1251.patch
+ epatch ${FILESDIR}/${P}-darwin.patch
}
src_compile() {