summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/bsdtar/bsdtar-1.02.027-r1.ebuild')
-rw-r--r--app-arch/bsdtar/bsdtar-1.02.027-r1.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/app-arch/bsdtar/bsdtar-1.02.027-r1.ebuild b/app-arch/bsdtar/bsdtar-1.02.027-r1.ebuild
index 5536f174543a..0627109a1d64 100644
--- a/app-arch/bsdtar/bsdtar-1.02.027-r1.ebuild
+++ b/app-arch/bsdtar/bsdtar-1.02.027-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/bsdtar-1.02.027-r1.ebuild,v 1.2 2005/06/21 12:51:03 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/bsdtar-1.02.027-r1.ebuild,v 1.3 2005/07/22 22:48:37 flameeyes Exp $
-inherit flag-o-matic
+inherit eutils flag-o-matic
DESCRIPTION="BSD tar command"
HOMEPAGE="http://people.freebsd.org/~kientzle/libarchive/"
@@ -10,7 +10,7 @@ SRC_URI="http://people.freebsd.org/~kientzle/libarchive/src/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~x86"
IUSE="build static"
# This is told to be used ( !elibc_glibc? ( dev-libs/libgnugetopt ) ) but isn't
@@ -21,6 +21,13 @@ RDEPEND="app-arch/bzip2
DEPEND="~dev-libs/libarchive-${PV}
${RDEPEND}"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-osx.patch
+}
+
src_compile() {
( use static || use build ) && append-ldflags -static