summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/lm_sensors/files/digest-lm_sensors-2.6.31
-rw-r--r--sys-apps/lm_sensors/lm_sensors-2.6.3.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/lm_sensors/files/digest-lm_sensors-2.6.3 b/sys-apps/lm_sensors/files/digest-lm_sensors-2.6.3
new file mode 100644
index 000000000000..b40ad4c40e8f
--- /dev/null
+++ b/sys-apps/lm_sensors/files/digest-lm_sensors-2.6.3
@@ -0,0 +1 @@
+MD5 de7657a0c9ef8574aeaf2c4695b042ec lm_sensors-2.6.3.tar.gz 449145
diff --git a/sys-apps/lm_sensors/lm_sensors-2.6.3.ebuild b/sys-apps/lm_sensors/lm_sensors-2.6.3.ebuild
new file mode 100644
index 000000000000..246b28fa66fd
--- /dev/null
+++ b/sys-apps/lm_sensors/lm_sensors-2.6.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/lm_sensors-2.6.3.ebuild,v 1.1 2002/04/28 00:35:31 blocke Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Hardware Sensors Monitoring by lm_sensors"
+SRC_URI="http://www.netroedge.com/~lm78/archive/${P}.tar.gz"
+HOMEPAGE="http://www.netroedge.com/~lm78/"
+
+SLOT="0"
+
+DEPEND="virtual/linux-sources"
+
+src_compile () {
+
+ emake clean all || die "lm_sensors requires the source of a compatible kernel\nversion installed in /usr/src/linux and i2c support built as a modules"
+
+}
+
+src_install () {
+ emake DESTDIR=${D} PREFIX=/usr MANDIR=/usr/share/man install || die
+}
+
+pkg_postinst() {
+
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+
+ einfo
+ einfo "The lm_sensors hardware sensors package has been installed."
+ einfo
+ einfo "It is recommended that you read the lm_sensors documentation."
+ einfo "To enable lm_sensors you will need to compile i2c support in"
+ einfo "your kernel as a module and run /usr/sbin/sensors-detect to"
+ einfo "detect the hardware in your system."
+ einfo
+ einfo "Be warned, the probing of hardware in your system performed by"
+ einfo "sensors-detect could freeze your system. Also do not use"
+ einfo "lm_sensors on certain laptop models from IBM. See the lm_sensors"
+ einfo "documentation and website for more information."
+ einfo
+ einfo "IMPORTANT: When you merge this package it installs kernel modules"
+ einfo "that can only be used with the specific kernel version whose"
+ einfo "source is located in /usr/src/linux. If you upgrade to a new"
+ einfo "kernel, you will need to remerge the lm_sensors package to build"
+ einfo "new kernel modules."
+ einfo
+
+}