summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/bash-completion/ChangeLog8
-rw-r--r--app-shells/bash-completion/bash-completion-20050121-r3.ebuild63
-rw-r--r--app-shells/bash-completion/files/digest-bash-completion-20050121-r31
3 files changed, 71 insertions, 1 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index bace629cfecb..717800f6926c 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/bash-completion
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.108 2005/03/13 01:23:17 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.109 2005/03/16 12:45:39 ka0ttic Exp $
+
+*bash-completion-20050121-r3 (16 Mar 2005)
+
+ 16 Mar 2005; Aaron Walker <ka0ttic@gentoo.org>
+ +bash-completion-20050121-r3.ebuild:
+ Revision bump; broke gentoo-bashcomp out into its own ebuild. Added as PDEPEND.
13 Mar 2005; Marcus D. Hanwell <cryos@gentoo.org> :
Marked stable on amd64.
diff --git a/app-shells/bash-completion/bash-completion-20050121-r3.ebuild b/app-shells/bash-completion/bash-completion-20050121-r3.ebuild
new file mode 100644
index 000000000000..88f83c76779f
--- /dev/null
+++ b/app-shells/bash-completion/bash-completion-20050121-r3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20050121-r3.ebuild,v 1.1 2005/03/16 12:45:39 ka0ttic Exp $
+
+inherit eutils
+
+DESCRIPTION="Programmable Completion for bash"
+HOMEPAGE="http://www.caliban.org/bash/index.shtml#completion"
+SRC_URI="http://www.caliban.org/files/bash/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~ppc-macos ~s390 ~sparc ~x86"
+IUSE=""
+
+DEPEND="app-arch/tar
+ app-arch/bzip2"
+RDEPEND="|| (
+ >=app-shells/bash-2.05a
+ app-shells/zsh
+ )"
+PDEPEND="app-shells/gentoo-bashcomp"
+
+S="${WORKDIR}/${PN/-/_}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gentoo.diff
+}
+
+src_install() {
+ insinto /etc
+ doins bash_completion || die "failed to install bash_completion"
+ exeinto /etc/profile.d
+ doexe ${FILESDIR}/bash-completion || die "failed to install profile.d"
+
+ # dev-util/subversion provides an extremely superior completion
+ rm contrib/subversion
+ insinto /usr/share/bash-completion
+ doins contrib/* || die "failed to install contrib completions"
+
+ dodoc Changelog README
+}
+
+pkg_postinst() {
+ echo
+ einfo "Add the following line to your ~/.bashrc to"
+ einfo "activate completion support in your bash:"
+ einfo "[ -f /etc/profile.d/bash-completion ] && . /etc/profile.d/bash-completion"
+ einfo
+ einfo "Additional complete functions can be enabled by symlinking them from"
+ einfo "/usr/share/bash-completion to /etc/bash_completion.d"
+ echo
+
+ if has_version 'app-shells/zsh' ; then
+ einfo "If you are interested in using the provided bash completion functions with"
+ einfo "zsh, valuable tips on the effective use of bashcompinit are available:"
+ einfo " http://www.zsh.org/mla/workers/2003/msg00046.html"
+ einfo " http://zshwiki.org/ZshSwitchingTo"
+ echo
+ fi
+}
diff --git a/app-shells/bash-completion/files/digest-bash-completion-20050121-r3 b/app-shells/bash-completion/files/digest-bash-completion-20050121-r3
new file mode 100644
index 000000000000..5b0dcdfbb97e
--- /dev/null
+++ b/app-shells/bash-completion/files/digest-bash-completion-20050121-r3
@@ -0,0 +1 @@
+MD5 fafeed562b01a8dee079eb851579f2d2 bash-completion-20050121.tar.bz2 90140