summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-themes/gnome-colors-common/ChangeLog10
-rw-r--r--x11-themes/gnome-colors-common/gnome-colors-common-5.5.1.ebuild57
-rw-r--r--x11-themes/gnome-colors-common/metadata.xml9
-rw-r--r--x11-themes/gnome-colors-themes/ChangeLog11
-rw-r--r--x11-themes/gnome-colors-themes/gnome-colors-themes-5.5.1.ebuild48
-rw-r--r--x11-themes/gnome-colors-themes/metadata.xml9
6 files changed, 144 insertions, 0 deletions
diff --git a/x11-themes/gnome-colors-common/ChangeLog b/x11-themes/gnome-colors-common/ChangeLog
new file mode 100644
index 000000000000..b4c240539af0
--- /dev/null
+++ b/x11-themes/gnome-colors-common/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-themes/gnome-colors-common
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-colors-common/ChangeLog,v 1.1 2010/02/09 13:19:29 pacho Exp $
+
+*gnome-colors-common-5.5.1 (09 Feb 2010)
+
+ 09 Feb 2010; Pacho Ramos <pacho@gentoo.org>
+ +gnome-colors-common-5.5.1.ebuild, +metadata.xml:
+ New ebuilds for gnome-colors iconsets, this one is for shared icons
+
diff --git a/x11-themes/gnome-colors-common/gnome-colors-common-5.5.1.ebuild b/x11-themes/gnome-colors-common/gnome-colors-common-5.5.1.ebuild
new file mode 100644
index 000000000000..6dfda65846b2
--- /dev/null
+++ b/x11-themes/gnome-colors-common/gnome-colors-common-5.5.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-colors-common/gnome-colors-common-5.5.1.ebuild,v 1.1 2010/02/09 13:19:29 pacho Exp $
+
+EAPI=2
+inherit gnome2-utils
+
+DESCRIPTION="Colorized icons shared between all gnome-colors iconsets"
+HOMEPAGE="http://code.google.com/p/gnome-colors/"
+
+SRC_URI="http://gnome-colors.googlecode.com/files/gnome-colors-${PV}.tar.gz
+ branding? ( http://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+branding"
+
+RDEPEND="x11-themes/gnome-icon-theme"
+DEPEND=""
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ if use branding; then
+ for i in 16 22 24 32 ; do
+ cp tango-gentoo-v1.1/${i}x${i}/gentoo.png \
+ gnome-colors-common/${i}x${i}/places/start-here.png \
+ || die "Copying gentoo logos failed"
+ done
+ cp tango-gentoo-v1.1/scalable/gentoo.svg \
+ gnome-colors-common/scalable/places/start-here.svg \
+ || die "Copying scalable logo failed"
+ fi
+}
+
+src_compile() {
+ einfo "Nothing to compile"
+}
+
+src_install() {
+ dodir /usr/share/icons
+ insinto /usr/share/icons
+ doins -r "${WORKDIR}/${PN}" || die "Installing icons failed"
+ dodoc AUTHORS ChangeLog README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/x11-themes/gnome-colors-common/metadata.xml b/x11-themes/gnome-colors-common/metadata.xml
new file mode 100644
index 000000000000..c421ccfa9302
--- /dev/null
+++ b/x11-themes/gnome-colors-common/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <maintainer>
+ <email>pacho@gentoo.org</email>
+ <name>Pacho Ramos</name>
+ </maintainer>
+</pkgmetadata> \ No newline at end of file
diff --git a/x11-themes/gnome-colors-themes/ChangeLog b/x11-themes/gnome-colors-themes/ChangeLog
new file mode 100644
index 000000000000..f1778ac0a0cc
--- /dev/null
+++ b/x11-themes/gnome-colors-themes/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-themes/gnome-colors-themes
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-colors-themes/ChangeLog,v 1.1 2010/02/09 13:21:18 pacho Exp $
+
+*gnome-colors-themes-5.5.1 (09 Feb 2010)
+
+ 09 Feb 2010; Pacho Ramos <pacho@gentoo.org>
+ +gnome-colors-themes-5.5.1.ebuild, +metadata.xml:
+ New ebuilds for gnome-colors iconsets, this one is for colorized themes,
+ including a Gentoo one
+
diff --git a/x11-themes/gnome-colors-themes/gnome-colors-themes-5.5.1.ebuild b/x11-themes/gnome-colors-themes/gnome-colors-themes-5.5.1.ebuild
new file mode 100644
index 000000000000..980de0c24ce1
--- /dev/null
+++ b/x11-themes/gnome-colors-themes/gnome-colors-themes-5.5.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-colors-themes/gnome-colors-themes-5.5.1.ebuild,v 1.1 2010/02/09 13:21:18 pacho Exp $
+
+EAPI=2
+inherit gnome2-utils
+
+DESCRIPTION="Some gnome-colors iconsets including a Gentoo one"
+HOMEPAGE="http://code.google.com/p/gnome-colors/"
+
+SRC_URI="http://gnome-colors.googlecode.com/files/gnome-colors-${PV}.tar.gz
+ http://dev.gentoo.org/~pacho/gnome-gentoo-${PV}.tar.gz"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-themes/gnome-colors-common"
+DEPEND=""
+RESTRICT="binchecks strip"
+
+src_compile() {
+ einfo "Nothing to compile"
+}
+
+src_install() {
+ dodir /usr/share/icons
+ insinto /usr/share/icons
+ for i in gnome*; do
+ if [ "$i" != "gnome-colors-common" ]; then
+ doins -r "${i}" || die
+ fi
+ done
+ dodoc AUTHORS ChangeLog README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/x11-themes/gnome-colors-themes/metadata.xml b/x11-themes/gnome-colors-themes/metadata.xml
new file mode 100644
index 000000000000..c421ccfa9302
--- /dev/null
+++ b/x11-themes/gnome-colors-themes/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <maintainer>
+ <email>pacho@gentoo.org</email>
+ <name>Pacho Ramos</name>
+ </maintainer>
+</pkgmetadata> \ No newline at end of file