summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/lxc/ChangeLog7
-rw-r--r--app-emulation/lxc/Manifest10
-rw-r--r--app-emulation/lxc/lxc-0.7.3.ebuild108
3 files changed, 120 insertions, 5 deletions
diff --git a/app-emulation/lxc/ChangeLog b/app-emulation/lxc/ChangeLog
index b4287d9aecf8..e56afd25529b 100644
--- a/app-emulation/lxc/ChangeLog
+++ b/app-emulation/lxc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/lxc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/ChangeLog,v 1.16 2010/10/15 14:29:40 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/ChangeLog,v 1.17 2010/11/16 14:14:55 flameeyes Exp $
+
+*lxc-0.7.3 (16 Nov 2010)
+
+ 16 Nov 2010; Diego E. Pettenò <flameeyes@gentoo.org> +lxc-0.7.3.ebuild:
+ Version bump; this also solves bug #345259.
15 Oct 2010; Diego E. Pettenò <flameeyes@gentoo.org> -lxc-0.7.1.ebuild:
Cleanup old version.
diff --git a/app-emulation/lxc/Manifest b/app-emulation/lxc/Manifest
index 80b5caf83516..b915301af957 100644
--- a/app-emulation/lxc/Manifest
+++ b/app-emulation/lxc/Manifest
@@ -3,13 +3,15 @@ Hash: SHA1
AUX lxc.initd 3198 RMD160 040fe0799306a781201500b5cd6b4fd1b23a2b39 SHA1 159d86282ba7be1541b7e1899a935cf4688ef0db SHA256 14a918e913173b1c9d3782e9b3df2471bb9d715df1d9d3f1e030f42da62f6d69
DIST lxc-0.7.2.tar.gz 266877 RMD160 3c4f2a751c1f4965bab75d9825e4d9d0642a4a4b SHA1 75dfc113a576fa15d46a3736ff788a168de0b258 SHA256 0660edbc08d74275968cb18c8e634aafd6f1ad395419e037d7018f2b1d669b1a
+DIST lxc-0.7.3.tar.gz 269712 RMD160 e7a3e157ac2d82cf655da4cea909c35474be100c SHA1 507f81d71ba963e6e9eb1b3cae6f6f5e103be9c2 SHA256 fa3b28cdb79b7c4735eaa8535dd014f94c8b7683d8ce2934d5836d241f48da09
EBUILD lxc-0.7.2-r1.ebuild 3073 RMD160 b04383df106bf68dfc65967c595ae0ac2c25ed02 SHA1 0b5663325909d39b8682603293b2dc1db893c169 SHA256 0118908c15e225b06efca3648d6734a384faa3443c84709e2ae4861615c67402
-MISC ChangeLog 3967 RMD160 f77a1648246e2aaca31325a7931e26ee67173de8 SHA1 c94340b09b35ccb9f7476c8ba1e188ab62e34e7c SHA256 8038745085e423d6555ce2de8bf36d9b351229f8395e4921ee46a214e68ee216
+EBUILD lxc-0.7.3.ebuild 3083 RMD160 2fdb44c84dd301e1eff40fcde5f2d7d348342bd3 SHA1 ab5e6dc38ed459566687ad385d01674733729382 SHA256 f34f00b6219dd2dc001136efa0d6bc48e97eaeb4c46017da2b21d4c0019857bc
+MISC ChangeLog 4115 RMD160 0b1548030574f5fe151fdbe05a4190f211c24cf7 SHA1 24cc43bb8c7e99791ea570106d41c5071ad6a16f SHA256 d6b300e7e9049c1e749ad1a0993b276278b05f286e0e31eafa710ca9d18ddb5a
MISC metadata.xml 653 RMD160 d6139a7ce3a5dab18f33c7f111f2e7827c290723 SHA1 47ba631625b4f2b20e491a964e65c78dd236f6f2 SHA256 35f64761067f47ff7abd0e3f3cb57f4bab888a2546bf3267d59987505101a190
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.16 (GNU/Linux)
-iEYEARECAAYFAky4ZSkACgkQAiZjviIA2XgwFwCeJQ9hTTI38YFpTAnjHCIEiB0Z
-MLAAmweyUhFVibPYgxGBdZ/wDML54559
-=2M8l
+iEYEARECAAYFAkzikbsACgkQAiZjviIA2XiJygCgvmqK/Ev8ljETFgcuBg6M3y5B
+C84AmgNBrc8pl54r3NuAPPxLBp7ccEpt
+=pug4
-----END PGP SIGNATURE-----
diff --git a/app-emulation/lxc/lxc-0.7.3.ebuild b/app-emulation/lxc/lxc-0.7.3.ebuild
new file mode 100644
index 000000000000..dc14ed362252
--- /dev/null
+++ b/app-emulation/lxc/lxc-0.7.3.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/lxc-0.7.3.ebuild,v 1.1 2010/11/16 14:14:55 flameeyes Exp $
+
+EAPI="2"
+
+inherit eutils linux-info versionator base
+
+DESCRIPTION="LinuX Containers userspace utilities"
+HOMEPAGE="http://lxc.sourceforge.net/"
+SRC_URI="http://lxc.sourceforge.net/download/lxc/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="doc examples vanilla"
+
+RDEPEND="sys-libs/libcap"
+
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook-sgml-utils )
+ >=sys-kernel/linux-headers-2.6.29"
+
+# For init script, so protect with vanilla, they are not strictly
+# needed.
+RDEPEND="${RDEPEND}
+ vanilla? (
+ sys-apps/util-linux
+ app-misc/pax-utils
+ )"
+
+CONFIG_CHECK="~CGROUPS
+ ~CGROUP_NS ~CPUSETS ~CGROUP_CPUACCT
+ ~RESOURCE_COUNTERS ~CGROUP_MEM_RES_CTLR
+ ~CGROUP_SCHED
+
+ ~NAMESPACES
+ ~IPC_NS ~USER_NS ~PID_NS
+
+ ~DEVPTS_MULTIPLE_INSTANCES
+ ~CGROUP_FREEZER
+ ~UTS_NS ~NET_NS
+ ~VETH ~MACVLAN"
+
+ERROR_DEVPTS_MULTIPLE_INSTANCES="CONFIG_DEVPTS_MULTIPLE_INSTANCES: needed for pts inside container"
+
+ERROR_CGROUP_FREEZER="CONFIG_CGROUP_FREEZER: needed to freeze containers"
+
+ERROR_UTS_NS="CONFIG_UTS_NS: needed to unshare hostnames and uname info"
+ERROR_NET_NS="CONFIG_NET_NS: needed for unshared network"
+
+ERROR_VETH="CONFIG_VETH: needed for internal (inter-container) networking"
+ERROR_MACVLAN="CONFIG_MACVLAN: needed for internal (inter-container) networking"
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --bindir=/usr/sbin \
+ --docdir=/usr/share/doc/${PF} \
+ --with-config-path=/etc/lxc \
+ $(use_enable doc) \
+ $(use_enable examples) \
+ || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc AUTHORS CONTRIBUTING MAINTAINERS \
+ NEWS TODO README doc/FAQ.txt || die "dodoc failed"
+
+ # If the documentation is going to be rebuilt, the Makefiles will
+ # install the man pages themselves; if we're not going to, we
+ # still need to install them, as they are provided with the
+ # tarball in recent versions.
+ if ! use doc; then
+ doman doc/*.{1,5,7} || die
+ fi
+
+ rm -r "${D}"/usr/sbin/lxc-{setcap,ls} \
+ "${D}"/usr/share/man/man1/lxc-ls.1 \
+ || die "unable to remove extraenous content"
+
+ keepdir /etc/lxc
+
+ find "${D}" -name '*.la' -delete
+
+ use vanilla && return 0
+
+ # Gentoo-specific additions!
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ keepdir /var/log/lxc
+}
+
+pkg_postinst() {
+ if ! use vanilla; then
+ elog "There is an init script provided with the package now; no documentation"
+ elog "is currently available though, so please check out /etc/init.d/lxc ."
+ elog "You _should_ only need to symlink it to /etc/init.d/lxc.configname"
+ elog "to start the container defined into /etc/lxc/configname.conf ."
+ elog "For further information about LXC development see"
+ elog "http://blog.flameeyes.eu/tag/lxc" # remove once proper doc is available
+ elog ""
+ fi
+ ewarn "To use the lxc-debian and lxc-fedora commands, you need respectively"
+ ewarn "dev-util/debootstrap and sys-apps/yum."
+}