summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-vim/gentoo-syntax/ChangeLog8
-rw-r--r--app-vim/gentoo-syntax/Manifest20
-rw-r--r--app-vim/gentoo-syntax/files/digest-gentoo-syntax-200503181
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20050318.ebuild50
4 files changed, 74 insertions, 5 deletions
diff --git a/app-vim/gentoo-syntax/ChangeLog b/app-vim/gentoo-syntax/ChangeLog
index 55bd74139341..5f32a910c4fb 100644
--- a/app-vim/gentoo-syntax/ChangeLog
+++ b/app-vim/gentoo-syntax/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-vim/gentoo-syntax
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/ChangeLog,v 1.42 2005/03/17 09:14:13 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/ChangeLog,v 1.43 2005/03/18 01:35:34 ciaranm Exp $
+
+*gentoo-syntax-20050318 (18 Mar 2005)
+
+ 18 Mar 2005; Ciaran McCreesh <ciaranm@gentoo.org>
+ +gentoo-syntax-20050318.ebuild:
+ New version
17 Mar 2005; Michael Hanselmann <hansmi@gentoo.org>
gentoo-syntax-20050211-r1.ebuild:
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index e517f9ca141d..a5ea5320afdc 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,8 +1,20 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 10c03f2a576906ca02f4ecf4d623edcf gentoo-syntax-20050211-r1.ebuild 1934
-MD5 9771ca4ff90b56dddc4acfadc6f6a01e metadata.xml 250
-MD5 a3cf5ac6f0a585faecb4bd14182639f9 ChangeLog 7922
+MD5 5b426ed375979254c52b6454cb85415b ChangeLog 8063
+MD5 5bdf91c4e3f532ef47f65d16d66500cd gentoo-syntax-20050318.ebuild 1718
MD5 d9850ff541e29532c8cceb94d33edba2 gentoo-syntax-20041227.ebuild 1847
-MD5 c8e3ac5d8a31716f27516db1f6d138c9 files/digest-gentoo-syntax-20041227 74
-MD5 2ebb63d791d0b453712e27584f1b1c67 files/gentoo-syntax-20050211-fix-escapes.patch 558
+MD5 9771ca4ff90b56dddc4acfadc6f6a01e metadata.xml 250
MD5 298bb984862016f9d7de0f6861c3fd73 files/gentoo-syntax-20050211-fix-xml.patch 2149
+MD5 c8e3ac5d8a31716f27516db1f6d138c9 files/digest-gentoo-syntax-20041227 74
+MD5 81522f0df6f49c1c8c5d7f3c3cf18c93 files/digest-gentoo-syntax-20050318 74
MD5 4f56c7de174c5e2aef4d6217acbc46a3 files/digest-gentoo-syntax-20050211-r1 74
+MD5 2ebb63d791d0b453712e27584f1b1c67 files/gentoo-syntax-20050211-fix-escapes.patch 558
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFCOjBKLLFUmVNQ7rkRAt9zAJ0ewWfE8OPxt5lIJzy4jazp+f7EgACgp6+i
+gvQYbeWs50rDg2M1LMJ8R64=
+=ZQA4
+-----END PGP SIGNATURE-----
diff --git a/app-vim/gentoo-syntax/files/digest-gentoo-syntax-20050318 b/app-vim/gentoo-syntax/files/digest-gentoo-syntax-20050318
new file mode 100644
index 000000000000..97d075ce7000
--- /dev/null
+++ b/app-vim/gentoo-syntax/files/digest-gentoo-syntax-20050318
@@ -0,0 +1 @@
+MD5 51fb216baa0c24949c3cc20f3fcc35e9 gentoo-syntax-20050318.tar.bz2 17051
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20050318.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20050318.ebuild
new file mode 100644
index 000000000000..6c004600f439
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20050318.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/gentoo-syntax-20050318.ebuild,v 1.1 2005/03/18 01:35:34 ciaranm Exp $
+
+inherit eutils vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo Ebuild, Eclass, GLEP, ChangeLog and Portage
+Files syntax highlighting, filetype and indent settings"
+HOMEPAGE="http://developer.berlios.de/projects/gentoo-syntax"
+LICENSE="vim"
+KEYWORDS="~x86 ~sparc ~mips ~amd64 ~ppc ~ppc64 ~alpha ~ia64 ~arm ~hppa ~s390"
+SRC_URI="http://download.berlios.de/gentoo-syntax/${P}.tar.bz2"
+RESTRICT="primaryuri"
+
+IUSE="ignore-glep31"
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ else
+ einfo "Note for developers and anyone else who edits ebuilds:"
+ einfo " This release of gentoo-syntax now contains filetype rules to set"
+ einfo " fileencoding for ebuilds and ChangeLogs to utf-8 as per GLEP 31."
+ einfo " If you find this feature breaks things, please submit a bug and"
+ einfo " assign it to vim@gentoo.org. You can use the 'ignore-glep31' USE"
+ einfo " flag to remove these rules."
+ fi
+ echo
+ epause 5
+}
+