summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/bash/ChangeLog15
-rw-r--r--sys-apps/bash/bash-2.05a-r2.ebuild57
-rw-r--r--sys-apps/bash/files/config-top.h.diff12
-rw-r--r--sys-apps/bash/files/digest-bash-2.05a-r21
4 files changed, 76 insertions, 9 deletions
diff --git a/sys-apps/bash/ChangeLog b/sys-apps/bash/ChangeLog
index 87648a4a366c..aa6bc2baf2d7 100644
--- a/sys-apps/bash/ChangeLog
+++ b/sys-apps/bash/ChangeLog
@@ -1,13 +1,10 @@
# ChangeLog for sys-apps/bash
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/bash/ChangeLog,v 1.1 2002/02/01 21:53:36 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/bash/ChangeLog,v 1.2 2002/04/10 01:37:04 drobbins Exp $
-*bash-2.05a-r1 (1 Feb 2002)
+*bash-2.05a-r2 (09 Apr 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
+ 09 Apr 2002; Daniel Robbins <drobbins@gentoo.org> : New bash release that has
+ a patch to allow non-interactive login shells to inherit their environment.
+ This allows your prompt to be preserved after you start X. This closes bug
+ #1579.
diff --git a/sys-apps/bash/bash-2.05a-r2.ebuild b/sys-apps/bash/bash-2.05a-r2.ebuild
new file mode 100644
index 000000000000..22d46c1a2b7d
--- /dev/null
+++ b/sys-apps/bash/bash-2.05a-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/bash/bash-2.05a-r2.ebuild,v 1.1 2002/04/10 01:37:05 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The standard GNU Bourne again shell"
+SRC_URI="ftp://ftp.gnu.org/gnu/bash/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
+
+#A recent portage is needed since bash is dynamic.
+DEPEND=">=sys-libs/ncurses-5.2-r2 readline? ( >=sys-libs/readline-4.1-r2 ) >=sys-apps/portage-1.8"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ #enable non-interactive login shells; this patch allows your prompt
+ #to be preserved when you start X and closes bug #1579.
+ cat ${FILESDIR}/config-top.h.diff | patch -p0 -l || die
+}
+
+src_compile() {
+
+ local myconf
+ [ "`use readline`" ] && myconf="--with-installed-readline"
+ [ -z "`use nls`" ] && myconf="${myconf} --disable-nls"
+ ./configure --prefix=/ \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} \
+ --disable-profiling \
+ --with-curses \
+ --without-gnu-malloc \
+ ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
+ dodir /bin
+ mv ${D}/usr/bin/bash ${D}/bin
+ dosym bash /bin/sh
+
+ if [ -z "`use build`" ]
+ then
+ doman doc/*.1
+ if [ -z "`use readline`" ]
+ then
+ doman doc/*.3
+ fi
+ dodoc README NEWS AUTHORS CHANGES COMPAT COPYING Y2K
+ dodoc doc/FAQ doc/INTRO
+ else
+ rm -rf ${D}/usr
+ fi
+}
diff --git a/sys-apps/bash/files/config-top.h.diff b/sys-apps/bash/files/config-top.h.diff
new file mode 100644
index 000000000000..51367b300833
--- /dev/null
+++ b/sys-apps/bash/files/config-top.h.diff
@@ -0,0 +1,12 @@
+--- config-top.h.orig 2002-04-06 18:38:23.000000000 +0200
++++ config-top.h 2002-04-06 18:24:18.000000000 +0200
+@@ -56,7 +56,7 @@
+
+ /* Define this to make non-interactive shells begun with argv[0][0] == '-'
+ run the startup files when not in posix mode. */
+-/* #define NON_INTERACTIVE_LOGIN_SHELLS */
++#define NON_INTERACTIVE_LOGIN_SHELLS
+
+ /* Define this if you want bash to try to check whether it's being run by
+ sshd and source the .bashrc if so (like the rshd behavior). */
+
diff --git a/sys-apps/bash/files/digest-bash-2.05a-r2 b/sys-apps/bash/files/digest-bash-2.05a-r2
new file mode 100644
index 000000000000..5dc9061017e7
--- /dev/null
+++ b/sys-apps/bash/files/digest-bash-2.05a-r2
@@ -0,0 +1 @@
+MD5 eeabc3f624861c4a8a687f7701db3d06 bash-2.05a.tar.gz 1807947