summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/boost/ChangeLog6
-rw-r--r--dev-libs/boost/Manifest10
-rw-r--r--dev-libs/boost/boost-1.31.0.ebuild140
-rw-r--r--dev-libs/boost/files/digest-boost-1.31.01
4 files changed, 152 insertions, 5 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 4e35b431a111..56ba06ce5db8 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.74 2005/11/24 18:32:36 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.75 2005/11/25 18:46:45 morfic Exp $
+
+ 25 Nov 2005; Daniel Goller <morfic@gentoo.org> +boost-1.31.0.ebuild:
+ readding bad ebuild thanks to luabind depending on boost internals instead
+ of the interface
24 Nov 2005; Daniel Goller <morfic@gentoo.org> -boost-1.29.0.ebuild,
-boost-1.30.0.ebuild, -boost-1.30.2.ebuild, -boost-1.31.0.ebuild,
diff --git a/dev-libs/boost/Manifest b/dev-libs/boost/Manifest
index 6ae3bda15c50..e3c7e41654aa 100644
--- a/dev-libs/boost/Manifest
+++ b/dev-libs/boost/Manifest
@@ -1,17 +1,19 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 976da9565d53197ab1069b9a43f6b4ad ChangeLog 10317
+MD5 53d3469166fea9cd14a5e19d616e7110 ChangeLog 10485
+MD5 48a9e1b7d8d0a0b83513977929156c2d boost-1.31.0.ebuild 3975
MD5 16a0704d7282649d4c5920e3c8b39bee metadata.xml 343
MD5 ed908454c628414aca51241a5f875870 boost-1.33.0-r1.ebuild 5643
MD5 421fe3be35fd6d405bf2b3381d51867f boost-1.33.0.ebuild 6259
+MD5 4aa5a3b9a3818e9dce488a20cb5ff00b files/digest-boost-1.31.0 66
MD5 612f486fa190f86f9be3a17465036dd0 files/digest-boost-1.33.0 67
MD5 238bb8043f0cdc8bd91f81bd0b55f92a files/boost-alpha-threads.patch 1111
MD5 612f486fa190f86f9be3a17465036dd0 files/digest-boost-1.33.0-r1 67
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDhgdb/aM9DdBw91cRAqibAJsE7XBiMzBOS5D2f5e0VxyiAW9WKwCfQxWm
-NivF6NxbHYOsYLDoY4nOZ9I=
-=9ptM
+iD8DBQFDh1w0/aM9DdBw91cRApZRAJ0ZGi5FOE9FA8yPv9MlLaaDrU2bpwCfUcIQ
+XwoZNvfP5++qQxt60lCgfXA=
+=rSFk
-----END PGP SIGNATURE-----
diff --git a/dev-libs/boost/boost-1.31.0.ebuild b/dev-libs/boost/boost-1.31.0.ebuild
new file mode 100644
index 000000000000..b41799a50234
--- /dev/null
+++ b/dev-libs/boost/boost-1.31.0.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.31.0.ebuild,v 1.15 2005/11/25 18:46:45 morfic Exp $
+
+MyPV=${PV//./_}
+
+DESCRIPTION="Boost provides free peer-reviewed portable C++ source libraries."
+HOMEPAGE="http://www.boost.org"
+#SRC_URI="http://easynews.dl.sourceforge.net/sourceforge/boost/boost-${PV}.tar.bz2"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${MyPV}.tar.bz2"
+
+S=${WORKDIR}/${PN}_${MyPV}
+
+LICENSE="freedist"
+KEYWORDS="amd64 ~mips ppc ppc64 sparc x86"
+SLOT="1"
+IUSE="icc"
+
+# This would be a good place for someone to figure out how to get
+# boost to build nicely with icc, as it's documented to be doable.
+
+DEPEND="virtual/libc"
+RDEPEND=">=dev-util/yacc-1.9.1-r1
+ >=dev-lang/python-2.2.1
+ icc? ( >=dev-lang/icc-7.1 )"
+
+src_compile() {
+ local PYTHON_VERSION=$(/usr/bin/python -V 2>&1 | sed 's/Python \([0-9][0-9]*\.[0-9][0-9]*\)\..*/\1/')
+ local BOOST_TOOLSET
+ local arch
+
+ if use icc ; then
+ BOOST_TOOLSET="intel-linux"
+ else
+ BOOST_TOOLSET="gcc"
+ fi
+
+ # Build bjam, a jam variant, which is used instead of make
+ cd ${S}/tools/build/jam_src
+ ./build.sh ${BOOST_TOOLSET} || die "Failed to build bjam"
+ cd ${S}
+
+ if [ "${ARCH}" == "amd64" ]; then
+ arch=
+ else
+ arch=${ARCH}
+ fi
+
+ if [ "${ARCH}" == "ppc64" ]; then
+ pushd .
+ cd tools/build/jam_src
+ ln -sf bin.linuxppc bin.linuxppc64
+ popd
+ fi
+
+ if use icc ; then
+ ./tools/build/jam_src/bin.linux${arch}/bjam -j2 \
+ -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYTHON_VERSION} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sINTEL_LINUX_VERSION="70" || die "Failed to build boost libraries."
+ else
+ ./tools/build/jam_src/bin.linux${arch}/bjam ${MAKEOPTS} \
+ -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYTHON_VERSION} \
+ -sTOOLS=${BOOST_TOOLSET}
+
+ einfo "Don't worry if there are a few (probably 6) failures above."
+ einfo "Some targets merely need to be combined. Here goes:"
+
+ ./tools/build/jam_src/bin.linux${arch}/bjam \
+ -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYTHON_VERSION} \
+ -sTOOLS=${BOOST_TOOLSET} || die "Failed to build boost libraries."
+ fi
+}
+
+src_install () {
+ # Unfortunately boost doesn't provide a standard way to
+ # install itself. So it's done "manually" here.
+
+ # install libraries
+ find bin/boost/libs -type f -name \*.a -exec dolib.a {} \;
+ find bin/boost/libs -type f -name "*.so*" -exec dolib.so {} \;
+ #find bin/boost/libs -type l -name "*.so*" -exec dosym {} /usr/lib \;
+
+ # install source/header files
+
+ find boost -type f \
+ -exec install -D -m0644 {} ${D}/usr/include/{} \;
+
+ # install build tools
+ cd tools/build
+ #do_whatever is too limiting here, need to move bunch of different stuff recursively
+ dodir /usr/share/${PN}
+ cp -pPR b* c* index.html v1/ v2/ ${D}/usr/share/${PN}
+ cd ${S}
+
+ # install documentation
+ dodoc README
+ dohtml index.htm google_logo_40wht.gif c++boost.gif boost.css
+ dohtml -A pdf -r more
+ dohtml -r people
+ dohtml -r doc
+
+ find libs -type f -not -regex '^libs/[^/]*/build/.*' \
+ -and -not -regex '^libs/.*/test[^/]?/.*' \
+ -and -not -regex '^libs/.*/bench[^/]?/.*' \
+ -and -not -regex '^libs/[^/]*/tools/.*' \
+ -and -not -name \*.bat \
+ -and -not -name Jamfile\* \
+ -and -not -regex '^libs/[^/]*/src/.*' \
+ -and -not -iname makefile \
+ -and -not -name \*.mak \
+ -and -not -name .\* \
+ -and -not -name \*.dsw \
+ -and -not -name \*.dsp \
+ -exec \
+ install -D -m0644 \{\} ${D}/usr/share/doc/${P}/html/\{\} \;
+
+ #create symlinks for the libs
+ LocalPV="1_31"
+ cd ${D}/usr/lib
+ for fn in *.so*; do
+ baseName=${fn%%so*}
+ #.so symlinks
+ ln -s $fn ${baseName}so
+ #remove version from .so's and .a's
+ ln -s ${baseName}so ${baseName/-$LocalPV/}so
+ ln -s ${baseName}a ${baseName/-$LocalPV/}a
+ done
+ #and finally set "default" links to -gcc-mt versions
+ for fn in `ls -1 *.so|cut -d- -f1|sort|uniq`; do
+ ln -s $fn-gcc-mt.so $fn.so
+ ln -s $fn-gcc-mt.a $fn.a
+ done
+}
diff --git a/dev-libs/boost/files/digest-boost-1.31.0 b/dev-libs/boost/files/digest-boost-1.31.0
new file mode 100644
index 000000000000..bd71acf23d9a
--- /dev/null
+++ b/dev-libs/boost/files/digest-boost-1.31.0
@@ -0,0 +1 @@
+MD5 8cc183538eaa5cfc53d88d0e94bd2fd4 boost_1_31_0.tar.bz2 6979482