summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-kernel/win4lin-sources/ChangeLog9
-rw-r--r--sys-kernel/win4lin-sources/files/digest-win4lin-sources-2.4.20-r13
-rw-r--r--sys-kernel/win4lin-sources/win4lin-sources-2.4.20-r1.ebuild37
3 files changed, 49 insertions, 0 deletions
diff --git a/sys-kernel/win4lin-sources/ChangeLog b/sys-kernel/win4lin-sources/ChangeLog
new file mode 100644
index 000000000000..107c4436c384
--- /dev/null
+++ b/sys-kernel/win4lin-sources/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-kernel/win4lin-sources
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/win4lin-sources/ChangeLog,v 1.1 2002/12/12 18:47:07 lostlogic Exp $
+
+*win4lin-sources-2.4.20-r1 (12 Dec 2002)
+
+ 12 Dec 2002; Brandon Low <lostlogic@gentoo.org>; win4lin-sources-2.4.20-r1.ebuild :
+ The first release of the win4lin-sources in Gentoo. This kernel should
+ allow licensed or trial users of Win4Lin to run their systems :)
diff --git a/sys-kernel/win4lin-sources/files/digest-win4lin-sources-2.4.20-r1 b/sys-kernel/win4lin-sources/files/digest-win4lin-sources-2.4.20-r1
new file mode 100644
index 000000000000..327dc7cee1d2
--- /dev/null
+++ b/sys-kernel/win4lin-sources/files/digest-win4lin-sources-2.4.20-r1
@@ -0,0 +1,3 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 32e4cda45fa0f090dffa157bc4504a4e mki-adapter.patch 181483
+MD5 393b5808d399426e18ea9da24d428b62 Kernel-Win4Lin3-2.4.20.patch 22588
diff --git a/sys-kernel/win4lin-sources/win4lin-sources-2.4.20-r1.ebuild b/sys-kernel/win4lin-sources/win4lin-sources-2.4.20-r1.ebuild
new file mode 100644
index 000000000000..74a692eea79c
--- /dev/null
+++ b/sys-kernel/win4lin-sources/win4lin-sources-2.4.20-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/win4lin-sources/win4lin-sources-2.4.20-r1.ebuild,v 1.1 2002/12/12 18:47:07 lostlogic Exp $
+
+IUSE="build"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+ETYPE="sources"
+
+inherit kernel || die
+
+OKV="2.4.20"
+
+#add one of these in if this is for a pre or rc kernel
+#KERN_PATCH="patch-2.4.20-rc1.bz2"
+
+DESCRIPTION="Full sources for the latest ACPI Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ https://www.netraverse.com/member/downloads/files/mki-adapter.patch
+ https://www.netraverse.com/member/downloads/files/Kernel-Win4Lin3-${OKV}.patch"
+#http://www.kernel.org/pub/linux/kernel/v2.4/testing/${KERN_PATCH}
+
+KEYWORDS="x86"
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+
+ cd linux-${KV}
+
+# bzcat ${DISTDIR}/${KERN_PATCH}|patch -p1 || die "-marcelo patch failed"
+ cat ${DISTDIR}/mki-adapter_1_0_7.patch|patch -p1 || die "-mki-adapter patch failed"
+ cat ${DISTDIR}/Kernel-Win4Lin3-${OKV}.patch|patch -p1 || die "-Win4Lin3 patch failed"
+
+ kernel_universal_unpack
+}