summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/coreutils/ChangeLog9
-rw-r--r--sys-apps/coreutils/Manifest12
-rw-r--r--sys-apps/coreutils/coreutils-5.0.91-r1.ebuild154
-rw-r--r--sys-apps/coreutils/files/digest-coreutils-5.0.91-r12
4 files changed, 171 insertions, 6 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index 36c517947764..c03b0cbfc0b2 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/coreutils
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.45 2003/11/05 01:30:10 brad_mssw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.46 2003/11/18 21:59:38 pebenito Exp $
+
+*coreutils-5.0.91-r1 (18 Nov 2003)
+
+ 18 Nov 2003; Chris PeBenito <pebenito@gentoo.org>
+ coreutils-5.0.91-r1.ebuild:
+ Bump to update SELinux patch. The old patch had a rare segfault/hang problem
+ in ls. Otherwise, same as -r0.
04 Nov 2003; Brad House <brad_mssw@gentoo.org> coreutils-5.0.91.ebuild:
mark stable on amd64
diff --git a/sys-apps/coreutils/Manifest b/sys-apps/coreutils/Manifest
index bd3794ff19aa..abd4e461d96b 100644
--- a/sys-apps/coreutils/Manifest
+++ b/sys-apps/coreutils/Manifest
@@ -1,11 +1,13 @@
-MD5 2da9d929e746c11911515b1a8007b71e coreutils-5.0-r4.ebuild 3093
MD5 e10f74a887e9a98519b9cae371c9bc09 coreutils-5.0-r1.ebuild 2604
-MD5 f5db1187cb599c540bddd31825f474c3 coreutils-5.0-r3.ebuild 2750
-MD5 9d4ca6279540226192fecba0ed77d5b2 coreutils-5.0.91.ebuild 3872
-MD5 3bf9f76092cc91b0e95c56fe1248c9db ChangeLog 8356
MD5 8179673a7f1ce30bb418033e617f2f20 coreutils-5.0-r2.ebuild 2635
-MD5 b5d176b166158cfe97d58ad43eec055e files/digest-coreutils-5.0.91 149
+MD5 f5db1187cb599c540bddd31825f474c3 coreutils-5.0-r3.ebuild 2750
+MD5 2da9d929e746c11911515b1a8007b71e coreutils-5.0-r4.ebuild 3093
+MD5 52a9e0abbbcad646c0a9f847114cef0f coreutils-5.0.91.ebuild 3872
+MD5 9c6b6cae18f70053b4ba5fea2f80a234 coreutils-5.0.91-r1.ebuild 3874
+MD5 e3a866d1c7ff084d076411357a23707a ChangeLog 8685
MD5 c9b338f24be4a49f01620b40b0e18cfb files/digest-coreutils-5.0-r1 138
MD5 76472cadee79dff1a2a26d8ae8a74866 files/digest-coreutils-5.0-r2 138
MD5 981d1c1d7cf8006aa46b44f269697262 files/digest-coreutils-5.0-r3 138
MD5 e68c4bf70f7067710c3a52fc8d50d49d files/digest-coreutils-5.0-r4 139
+MD5 b5d176b166158cfe97d58ad43eec055e files/digest-coreutils-5.0.91 149
+MD5 166cd5ab4e6df4999088f49a0ad01aaf files/digest-coreutils-5.0.91-r1 149
diff --git a/sys-apps/coreutils/coreutils-5.0.91-r1.ebuild b/sys-apps/coreutils/coreutils-5.0.91-r1.ebuild
new file mode 100644
index 000000000000..21489789b787
--- /dev/null
+++ b/sys-apps/coreutils/coreutils-5.0.91-r1.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.0.91-r1.ebuild,v 1.1 2003/11/18 21:59:38 pebenito Exp $
+
+inherit eutils flag-o-matic
+
+IUSE="nls build acl selinux static"
+
+PATCH_VER="1.2"
+PATCHDIR="${WORKDIR}/patch"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls...), text utilities (sort, tr, head, wc..), and shell utilities (whoami, who,...)"
+HOMEPAGE="http://www.gnu.org/software/coreutils/"
+SRC_URI="mirror://gnu/coreutils/${P}.tar.bz2
+ mirror://gnu/coreutils/${P}.tar.bz2
+ mirror://coreutils/${P}.tar.bz2
+ mirror://gentoo/${P}-gentoo-${PATCH_VER}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 amd64 ppc ~sparc alpha hppa ~arm ~mips ia64"
+
+DEPEND="virtual/glibc
+ >=sys-apps/portage-2.0.49
+ sys-devel/automake
+ sys-devel/autoconf
+ sys-apps/help2man
+ nls? ( sys-devel/gettext )
+ acl? ( sys-apps/acl )
+ selinux? ( sys-libs/libselinux )"
+
+RDEPEND="selinux? ( sys-libs/libselinux )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ if use acl && use selinux
+ then
+ ewarn "Both ACL and SELINUX are not supported together!"
+ ewarn "Will Select SELINUX instead"
+ fi
+
+ # HPPA and ARM platforms do not work well with the uname patch
+ # (see below about it)
+ if use hppa || use arm
+ then
+ mv ${PATCHDIR}/003* ${PATCHDIR}/excluded
+ fi
+
+ # Apply the ACL patches.
+ # WARNING: These CONFLICT with the SELINUX patches
+ if use acl
+ then
+#
+# This one also needs porting like the rest, but its a bit more involved,
+# so I will leave it for somebody that use i18n that can actually test it.
+#
+# if [ -z "`use nls`" ] ; then
+ mv ${PATCHDIR}/acl/004* ${PATCHDIR}/excluded
+# fi
+
+ # This test do seem to be fixed in another way, the acl guys
+ # can just verify please ...
+ mv ${PATCHDIR}/acl/006* ${PATCHDIR}/excluded
+
+ use selinux || mv ${PATCHDIR}/001* ${PATCHDIR}/excluded
+ use selinux || EPATCH_SUFFIX="patch" epatch ${PATCHDIR}/acl
+ fi
+
+ # patch to remove Stallman's su/wheel group rant (which doesn't apply,
+ # since Gentoo's su is not GNU/su, but that from shadow.
+ # do not include su infopage, as it is not valid for the su
+ # from sys-apps/shadow that we are using.
+ # Patch to add processor specific info to the uname output
+
+ EPATCH_SUFFIX="patch" epatch ${PATCHDIR}
+
+ use selinux && EPATCH_SUFFIX="patch" epatch ${PATCHDIR}/selinux
+}
+
+src_compile() {
+ local myconf=
+ use nls || myconf="--disable-nls"
+
+ if use acl
+ then
+ if [ -z "`use selinux`" ]
+ then
+ if [ -z "`which cvs 2>/dev/null`" ]
+ then
+ # Fix issues with gettext's autopoint if cvs is not installed,
+ # bug #28920.
+ export AUTOPOINT="/bin/true"
+ fi
+ mv m4/inttypes.m4 m4/inttypes-eggert.m4
+ autoreconf --force --install || die
+ fi
+ fi
+
+ append-flags "-fPIC"
+
+ econf \
+ --bindir=/bin \
+ ${myconf} || die
+
+ if use static
+ then
+ emake LDFLAGS=-static || die
+ else
+ emake || die
+ fi
+}
+
+src_install() {
+ einstall \
+ bindir=${D}/bin || die
+
+ # hostname comes from net-base
+ # hostname does not work with the -f switch, which breaks gnome2
+ # amongst other things
+ rm -f ${D}/{bin,usr/bin}/hostname ${D}/usr/share/man/man1/hostname.*
+
+ # /bin/su comes from sys-apps/shadow
+ rm -f ${D}/{bin,usr/bin}/su ${D}/usr/share/man/man1/su.*
+
+ # /usr/bin/uptime comes from the sys-apps/procps packaga
+ rm -f ${D}/{bin,usr/bin}/uptime ${D}/usr/share/man/man1/uptime*
+
+ cd ${D}
+ dodir /usr/bin
+ rm -rf usr/lib
+ cd usr/bin
+ ln -s ../../bin/* .
+
+ if [ -z "`use build`" ]
+ then
+ cd ${S}
+ dodoc AUTHORS ChangeLog* COPYING NEWS README* THANKS TODO
+ else
+ rm -rf ${D}/usr/share
+ fi
+}
+
+pkg_postinst() {
+ # hostname does not get removed as it is included with older stage1
+ # tarballs, and net-tools installs to /bin
+ if [ -e ${ROOT}/usr/bin/hostname ] && [ ! -L ${ROOT}/usr/bin/hostname ]
+ then
+ rm -f ${ROOT}/usr/bin/hostname
+ fi
+}
diff --git a/sys-apps/coreutils/files/digest-coreutils-5.0.91-r1 b/sys-apps/coreutils/files/digest-coreutils-5.0.91-r1
new file mode 100644
index 000000000000..a1f2a110acde
--- /dev/null
+++ b/sys-apps/coreutils/files/digest-coreutils-5.0.91-r1
@@ -0,0 +1,2 @@
+MD5 e62c18cde8b254c2512e47dd0c47c332 coreutils-5.0.91.tar.bz2 4183673
+MD5 84d6f2c5431eeb18cde3be630ef07abf coreutils-5.0.91-gentoo-1.2.tar.bz2 60423