summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--xfce-extra/transd/transd-0_p20101006.ebuild4
-rw-r--r--xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-0.5.1.ebuild24
-rw-r--r--xfce-extra/xfce4-eyes-plugin/xfce4-eyes-plugin-4.4.0.ebuild16
3 files changed, 26 insertions, 18 deletions
diff --git a/xfce-extra/transd/transd-0_p20101006.ebuild b/xfce-extra/transd/transd-0_p20101006.ebuild
index 2a6b6e05d28f..f941ac2b3a4d 100644
--- a/xfce-extra/transd/transd-0_p20101006.ebuild
+++ b/xfce-extra/transd/transd-0_p20101006.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/transd/transd-0_p20101006.ebuild,v 1.3 2010/12/13 18:46:52 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/transd/transd-0_p20101006.ebuild,v 1.4 2011/01/29 20:57:10 ssuominen Exp $
-EAPI=2
+EAPI=3
EAUTORECONF=yes
EINTLTOOLIZE=yes
inherit xfconf
diff --git a/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-0.5.1.ebuild b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-0.5.1.ebuild
index f10eb316891a..53ddf5a23251 100644
--- a/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-0.5.1.ebuild
+++ b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-0.5.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-0.5.1.ebuild,v 1.2 2011/01/06 16:20:45 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-0.5.1.ebuild,v 1.3 2011/01/29 21:03:10 ssuominen Exp $
-EAPI=2
+EAPI=3
inherit xfconf
DESCRIPTION="Battery status panel plugin"
@@ -23,11 +23,17 @@ DEPEND="${RDEPEND}
dev-util/intltool"
pkg_setup() {
- PATCHES=( "${FILESDIR}/${PV}-freebsd.patch"
- "${FILESDIR}/${PV}-libacpi.patch"
- "${FILESDIR}/${PV}-2.6.24-headers.patch"
- "${FILESDIR}/${PV}-sysfs.patch" )
+ PATCHES=(
+ "${FILESDIR}"/${PV}-freebsd.patch
+ "${FILESDIR}"/${PV}-libacpi.patch
+ "${FILESDIR}"/${PV}-2.6.24-headers.patch
+ "${FILESDIR}"/${PV}-sysfs.patch
+ )
+
DOCS="AUTHORS ChangeLog README"
- XFCONF="--disable-dependency-tracking
- $(use_enable debug)"
+
+ XFCONF=(
+ --disable-dependency-tracking
+ $(use_enable debug)
+ )
}
diff --git a/xfce-extra/xfce4-eyes-plugin/xfce4-eyes-plugin-4.4.0.ebuild b/xfce-extra/xfce4-eyes-plugin/xfce4-eyes-plugin-4.4.0.ebuild
index 29162fd378b9..a538ab82be35 100644
--- a/xfce-extra/xfce4-eyes-plugin/xfce4-eyes-plugin-4.4.0.ebuild
+++ b/xfce-extra/xfce4-eyes-plugin/xfce4-eyes-plugin-4.4.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-eyes-plugin/xfce4-eyes-plugin-4.4.0.ebuild,v 1.3 2009/10/08 17:33:46 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-eyes-plugin/xfce4-eyes-plugin-4.4.0.ebuild,v 1.4 2011/01/29 21:01:23 ssuominen Exp $
EAUTORECONF=yes
EINTLTOOLIZE=yes
-EAPI=2
+EAPI=3
inherit xfconf
DESCRIPTION="panel plugin that adds eyes which watch your every step"
@@ -25,14 +25,16 @@ DEPEND="${RDEPEND}
dev-util/intltool"
pkg_setup() {
- PATCHES=( "${FILESDIR}/${P}-libtool.patch" )
+ PATCHES=( "${FILESDIR}"/${P}-libtool.patch )
DOCS="AUTHORS ChangeLog README"
- XFCONF="--disable-dependency-tracking
- $(use_enable debug)"
+ XFCONF=(
+ --disable-dependency-tracking
+ $(use_enable debug)
+ )
}
src_prepare() {
sed -i -e "/^AC_INIT/s/eyes_version()/eyes_version/" \
- configure.in || die "sed failed"
+ configure.in || die
xfconf_src_prepare
}